Google Drive hosted Videos wont play

I know this has been raised in the thread below before but I don’t believe it has been satisfactorily resolved.

I’m doing some testing and I’m having issues with playing back .mp4 (3.4MB) videos hosted on my personal Google Drive. I uploaded the same video to YouTube and they playback fine.

Is there a bug?

Is the video shared to the public on your Google drive and are you using the public link? Can you view the video if you open the link in your browser using incognito mode?

Yes, it’s shared publicly and I’m using the public link.

I can view/play the video in Incognito Mode.

Why don’t you upload them to YouTube?
I’m sure they load faster and don’t use your own space in your GDrive.

It’s because I’m testing the feasibility of being able to purchase access to view the videos. When hosting on YouTube you’re able to get the public link to the videos quiet easy and therefore being able to bypass payment for access by simply sharing the URL to the video.

I have no concerns on the cost to host them on my google drive. Glide supposedly supports them being hosted on g-drive anyway :slight_smile:

Strange… Isn’t there any special character(s) in the video files names which would prevent them to be played?

yes very - there’s no strange chars in the name or spaces. :confused:

I wonder if the video was recorded in an incompatible codec. Is this a video that can be shared so we can look at it?

not at all - I was testing using a little showcase vid I did for another app I’m working on.

I’ve been trying to compare your video to one of my videos that I know works. I can’t seem to find much of a difference between the two other than the video dimensions. Mine is 1920x1080 vs your 1080x1080. I know mine is using the H264 codec, but I don’t have a way to find out yours. Those are the only things I can think of that may be different. Otherwise I think you are fine with how you have it shared. I just don’t know why Glide isn’t loading it.

thanks Jeff - do you get the same results using the link to my video on your end?

Yes I do. I can play the video just fine using the link in a browser window, but when I add it into an app, the video doesn’t load. When I change the link to one of my videos, then it loads just fine in the app.

very strange - I think it must be the video. I just tested another video (.mov) and it works perfectly fine.

1 Like

Same problem here with getting my Google Drive videos to work consistently on the app! Now, this reply may either help or complicate the issue…

I found the helps doc addressing videos in the Glide apps here: https://docs.glideapps.com/all/reference/components/media/video

The problem I thought I had - which I’m sure was part of the problem - was the size and format of some of the videos I tried using - .mp4 and <100MB.

However, after spending some time using Adobe Media Encoder to convert my videos to the right size and format, I have found that the videos went from never working to “only” rarely working on the app! That’s right, they sometimes work but usually don’t - I just get the play icon with the slash through it. The intermittent access seems to be random, because I won’t work on the app for a little while, and then the thumbnails will appear and the video will work. A minute later, they don’t.

Here’s what I can tell you about my videos, before I get all kinds of questions:

  • All permissions are set to publicly allow access to whoever has the links.
  • All videos are under 100MB and .mp4, per instructions.
  • Videos do seem to work in the online app builder, but not on my iPad (2018) or iPhone 11.
  • Thumbnails seem to show up seemingly random at times - at which times the videos DO work - but usually there’s only a “slashed” play button in the placeholder.

Would appreciate a word from someone that can say at least the issue has been acknowledged and is being worked on. Thank you!

Not sure if this is the case or not, but may be what you are experiencing.

Just an FYI. I am also experiencing this issue. All my videos are under 100mb, mp4 format, and publicly shared .