Glide Tables Export and Import Doesn't Work

Hello, I’m trying to export and import data from one version of the app to another.

Describe the bug:
I have ‘Row ID’ in both. I have encountered two problems while trying to export and import data:

  1. If the ‘Row ID’ name is “:lock: Row ID” in both apps, then while importing the data just nothing happens, the table stays empty.

  2. If I change the ‘Row ID’ name to “User ID” in both apps, then while importing the data, the ‘Row ID’ for every row is different from the original app and csv file. I have multiple dependencies in other tables based on the ‘Row ID’, and all of them will be broken.

Expected behavior:

  1. Import should be successful.
  2. Unique ‘Row ID’ have to match with source after import.

How to replicate:

  1. Open any app with table that have ‘Row ID’.
  2. Duplicate that app.
  3. Open duplicate and delete all data from the table that have ‘Row ID’.
  4. Export data from the source table.
  5. Import data to the table of duplicated app.
    – At this point import will not work, table will stay empty –
  6. Change “:lock: Row ID” to “User ID”(example) in both source and duplicate apps.
  7. Repeat steps: 4-5
    – At this point data will be imported, but the ‘Row ID’ will not match with source.

Link to demo recording (optional):

1 Like

hi. Did you ever resolve this? I’m having similar problems.

This is a bug - having the same issue

I have the same issue, no columns structure has been changed, but import works for some tables, for others don’t. This should be an essential feature when porting data to a new app version.

There is even no any log or error message displayed.

@david , any help here. It is annoying and breaking my new app versions development

I’ve also had issues with transferring data from one version of an App to another via export/import.
In my case, I experienced two issues:

  • Roles that were used as Row Owners did not work after import
  • Some text values are randomly being interpreted as Dates after import, specifically by the JSON Object column.

I have an open ticket with Glide support, which is still being investigated.
One “workaround” they have given me is to convert the exported CSV file to ODS format before importing. I tried this and it does appear to fix the Roles as Row Owners issue. I’ve not been able to confirm if it resolves the second issue.

I’ve not experienced the RowID issue that the OP referred to (touch wood). Thankfully that part of it has worked fine for me.

1 Like

RowID issue is very annoying. It breaks the whole purpose of having RowID column. I use RowID through entire app referenced from other tables thus creating another fake rowid before import to make the import work would be maintenance nightmare.

RowID is guaranteed unique across all apps and users?

The import tool should be done better and some logs being added

I switched from external DB sources to glide because I like all being integrated but this problem with import breaks the whole idea.

My app is still under testing and not being officially given to real users, but rather to few friends who are testing it. I can’t imagine what will happen in production when need to fix bugs across several maker apps.

If import doesn’t continue to work - I would need to go to each maker and add same features and bug fixes to all app instances instead of copying one single app version to my makers and then importing the data

1 Like

I’m not sure what to say about that, because as I said I haven’t had any problems with this. It’s also vital for me, because several of my tables are integrated with my clients database, and they use the RowID as a unique key. So when we switch Apps, it’s absolutely essential that the RowID values are preserved. And so far, it has worked.

I used to think that, but it’s obviously not the case. Because I can export the data from a table in one App, and import it into a table in another App (where the tables are not shared), and both tables will have identical RowID values. I think RowIDs are probably guaranteed to be unique per table.

1 Like

I forgot to mention my import and export tables have the same columns structure. And for some of them import worked and for some it didn’t

I did not know that! Thank you for sharing! Can we confirm with the Glide Team that this is true?

I’ll see if I can find out.