Glide data not updated until after 9:00

I have been running my app on the basic plan for a year and a half.
Since 9/12, the data is no longer reflected in the spreadsheet, even though the spreadsheet has the data.
And every day since then, without fail, the data suddenly appears after 9:00.
The data source is Google SpreadSheet and the filter is set to show only the data of the day.(DATE is within today.)

Since we are using this service in Japan, it is probably because the time zone is UTC to determine if it is today or not.
Is there somewhere I can set the time zone for the application?
Or is there a way to have it determine if it is today in JST?

You could try changing the timezone of your GSheet.

File > Spreadsheet Settings > General > Timezone


Spreadsheet data must be maintained in JST.
Glide should make the decision based on time zone.
Also, it was working fine until Sept. 12, did something change?

How is the date/time column configured in the Glide Data Editor?
Can you show me?

Also, if you click inside one of the cells inside the Data Editor, does the value match what you would expect to see?

Screen Shot 2022-10-13 at 1.35.09 PM

Thx for reply.
Glide has the same content as the spreadsheet.


Okay, that looks fine.

How about your filtering - do you do that inside the data editor, or as a filter condition on a list?

Again, can you show me please?

Thanks,filter setting is here.

For your second filter condition, please try changing that to “is not checked”

Thanks, Darren. I’l check it later, inform you the result.

The result is not changed.
If the problem is due to the time zone, the previous day’s data should be displayed until 9:00, but nothing is displayed after 0:00.
Therefore, we assume that this is not a time zone issue, but rather that a process was incorporated around September 12 that does not reflect today’s data until 9:00.

One of your screenshots shows an underlying time of 9:15. Do all of your dates consistently have a time on or after 9:00?


Sorry too late. Yes.

Sorry, I lied. the dates contains a time before 9:00. but, not displayed.

I don’t know if you’ve seen this post I’ve attached below, but it sounds like it’s the same issue. If you read through it, @Darren_Murphy provided an alternative solution that should take care of your issue as well. It does seem like you have run into a bug that’s dependent on your timezone, so feel free to report that to Glide support if you want, but the Darren’s solution should work just as well for you.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.