Glide API not updating in UI

Hello everyone,

I’ve been struggling with a problem and couldn’t find any solution for it. I have firebase function that I call by pressing a button in glide, this function does some calculation then using Glide Table API adds back multiple records to a certain table using an array of “mutation” to do batch adds in a single API call. the data gets inserted into gsheets immediately but it takes too long to appear in glide. I thought since I am adding the data using official Glide API this should refreshes glide tables but it is doesn’t. I tried walkarounds to force refresh by incrementing a certain value in that sheet but till not updating.

I’ve also tried to not do it in batch call, and do an API call for each row to be added and still the same. I am on Pro plan and extra reads activated in settings

Thanks in advance🌷

Was that workaround triggered from an action in Glide?.. still too long?

Yes, I couldnt get it to refresh.
But I figured out the problem is that the Glide designer it self is slow in updating in such scenario.When I published the app then updates started to appear immediately (without refreshing) so the problem is that I was testing in the Glide designer instead of a published app for this special case.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.