Getting 'Unauthorized' Error when pushing data to Edit Rows API


@Vishal_Chatre and I are working on a payment gateway integration with our app. We have manged to send the relevant data from glide tables to make and made an HTTP call to the payment gateway website.

We have been able to reach the stage where - the first HTTP call generates the payment link and the gateway in the output of the HTTP call sends data.

Now, we want to pass this data back to our glide tables so that the customers gets a real time payment gateway screen

We connected another HTTP request to the prev HTTP request.

However, in the second HTTP call, we are getting the following error -

Screenshot 2023-04-11 at 6.23.25 PM

What should we do?


Are you sending the correct API token in the request headers?

Can you show a screen shot of your HTTP module configuration? (be sure to redact your token value if it is there).

Thanks for your response, Darren!

pfa the screenshot

You are missing Content-Type: application/json in your request header.

If fixing that doesn’t resolve the issue, then I would suggest carefully checking both your token and App ID values. Make sure they are correct and don’t contain any trailing spaces.

1 Like


May I know why is this part structured like this? I thought it should be in reverse:

“rowID”: “your row ID here”.

You are pointing a variable to a key instead of a value.

@Darren_Murphy I think the “Content Type” variable just above the request content covers it.


We will try these things in a bit and we will get back. Thanks for your responses.

hmm, not 100% sure that it makes a difference, but I normally also include it explicitly in the request header. Here is what one of my calls typically looks like:

1 Like

Thanks for your help, @Darren_Murphy & @ThinhDinh!

Making these changes seems to have worked. Now, the status code is 200 as in the attached screenshot. However, the data has not been added to the Glide table.

I made the following changes-

  1. changed the order of the rowID
  2. added content type to the header

not sure why data is not getting populated back in the Glide table.

Any thoughts?

Are you sending the correct RowID value?

Yes, I checked that in the ‘Request content’. The data being sent is correct. Does it likely have to do with the reverse order of the rowID? I had changed it based on @ThinhDinh’s comment. Should I reverse it? Will check that now.

From your earlier screen shot:

CleanShot 2023-04-12 at 14.41.06@2x

Putting aside the fact that in the screen shot you have the key and value back to front (which you said you fixed), have you confirmed that the value assigned to “merchant_txn” corresponds to the correct RowID in the destination Glide Table?

We tried multiple things, we even tried ‘Add Row’ API. We’re getting 200 as status code but blank response from API. The request content is correct, however, the response we receive is blank in glide tables.

Data from the HTTP (5) response is not populating the glide table. Only row id is getting generated. The rest of the values are all blank.

We are on the Pro for Business Subscription. Does it have anything to do with this?

I don’t know what a “Pro for Business” subscription is. There is Pro, and there is Business, so you either have one or the other. Regardless, you either have API access or you don’t, and obviously you do.

Can you show me a screen shot of the Glide Table that you are trying to add a row to, that includes the column headers?

here it is…

These are all the ids that are generated by the ‘Add-Row’ API request… However, the data getting passed is all blank

Okay, so the rows are being added, but the column values are blank.
That suggests to me that there could be a mis-match with the column names. Are you passing the correct column names, as per the example you get with “Show API Usage…” ?

Yes, we are… we have simply copied and pasted the ‘Show API’ - ‘Add row’ cURL content to the request content while configuring HTTP module. Here is the sample request content that has gone through in the input of the HTTP module –

HTTP Request Content



Once again, row id is generated and not values in columns.

We are referring to this youtube video – Glide API: Connect ANY platform to your Glide App! - YouTube

It looks like you have all the keys and values mixed up, the same as you did with the RowID.

The value on the left hand side should be the column name that Show API Usage gives you, and the value on the right hand side should be the value that you want to set it to.

We tried it the other way too. We are getting the same response.

For your info- this is how I see the ‘Show API’ page.

Okay, so you should be using those column names as they are shown. eg, bZZmy for your Quotation ID, hY2qr for the Easebuzz ID, etc…


It worked. Thank you, @Darren_Murphy. Your help is invaluable to us. We are happy that you are quick to respond and always ready to help.

You’re a rockstar!