Getting a error when trying to add my rep in experimental code column

Hi Everybody,

Trying to add a rep which I created but getting a error! Check this video : Rep error.mp4 - Google Drive

I hope that someone can help me! :smiley:

Thank you and Have a great day!

Update :

Just tried again and the issue is solved!


But getting a loading spinner and not giving me the result! Do you guys know whats the issue?

Thanks again!

I’m just curious as to why you don’t just use a JavaScript column for this?

1 Like

Thanks Darren for replying!

I tried to use that but the crypto.js library is supported and did it like this!

If you know how to do this with JS column that would be great! Thanks again!

Check the below:

I checked that too but didn’t found the package for crypto.js. The progress bar doesn’t fully finish!

Am I missing something?

Did you try importing the cloudflare one?

Maybe because your function doesn’t actually return anything? :wink:

Yep but without success!

Hmm… What should I have to do? This doesn’t returns anything?

import * as CryptoJS from '';

const message = 'hello';
const secretKey = 'secret';

const hmac = CryptoJS.HmacSHA1(message, secretKey);
const hashHex = CryptoJS.enc.Hex.stringify(hmac);

return hashHex;

You need a return statement.
So instead of console.log(hashHex), you should have return hashHex

Tried that but still no luck :no_mouth:

Still the column is loading and getting a error a in replit!

With console.log() in replit :

Here’s the URL which I used in the experimental code column :

Still no luck with this!

Darren, sorry if I disturbed you! Do you think that, this is a bug or a mistake I did?

I don’t know.
If you want to move your repo to GitHub, and then give me the repo link, I can clone it and have a play with it. I might be able to get it working :man_shrugging:

Darren, I moved to github but still gets the same issue!


URL I used in the experimental code column :

Am I correct with github?

I opened the URL in a browser and I’m getting the result I need when I checked the console! I guess something wrong with my JS code?

I just forked it. I’ll take a look.

1 Like