Formatting in Google Sheet for Long/Lat Coordinates?

Hello all!
I am new to Glide so I may have problems with the basics.

I want my map in Glide to show the addresses from my Google sheet table. In Google sheet I use the add-on from “AwesomeTable” to generate the longitude and latitude from an address. As I understand it, the coordinates must be something like: 00,00… or -00,00…
But for me the coordinates are always separated by a dot after every three digits (e.g. 000.000.000…) I think this is also the reason why they are not displayed correctly on the map.
My question is, how do I have to format the cell in Googlesheet so that it is displayed like a correct Lat/Long condinate. Or do I need to do some formatting in GlideTable? I haven’t found a tutorial yet where someone shows it.

I hope I have described my problem in an understandable way.

Thanks for the help in advance!

The preferred format is Decimal Degreee (DD) notation.

For example, Latitude and Longitude should look something like this


I’m not sure what format 000.000.000 is supposed to represent, unless it’s supposed to be a form of DDM or DMS notation. I do have some math formulas to do the conversion between notations, but preferably, you could adjust a setting in your google sheet addon to us DD notation.

Thanks for your answer

In the picture you can see what this looks like for me, it just spits out 000,000,000 and I don’t know why.

Where can I set “Decimal Degree” for these two cells, I don’t know how to do it.
As you can see in the add-on (on the right), unfortunately I can’t make any settings. It just generates me the coordinates from my address column. Or is it possible, but how?

I don’t know anything about that add-on to google sheets. You will need to find some documentation on how to use it, or find out what format it’s actually returning.

Or…it’s possible that you just need to adjust the formatting for the column in the google sheet.

On the surface, it looks like it starts out as valid degrees, but I’d lean towards some weird column formatting that’s adding the extra decimals and putting them in weird spots.

now it shows like it should.

I am from Germany and of course I use the German version of Sheets. When I went into the settings and changed the program as well as the functions to English, it suddenly worked.
Who would have thought that xD

Thanks anyway for the help!


Ah, OK. Looks like Germany uses a period (.) for a thousands separator and a comma (,) for a decimal. Must have been confusing the two from the add-on and treating them as very large numbers.

I’m not sure, but you may be able to keep the sheet as German, but change the latitude and longitude columns to a text format, so they aren’t read as numbers by the sheet.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.