Favorites not staying as changed


Having a problem with Favorites in the app I’m creating. The table has RowID, and an “IsFavorite” column. My issue is that when I denote something (a recipe) as a favorite, and then try to unselect it, it reverts back to being a Favorite after a few seconds. Additionally, I have another page which has an inline list that I want to showcase a user’s favorites. Once a favorite is identified and show on that page, I can’t get it to be unfavorited so that it doesn’t show anymore.

Is this a bug, or is it just user (me) error? Any help would be appreciated.

Jim Spellos

Having this same issue too. Any insights on how to fix?

I had something not working with my relation field. I deleted it and re-established it, and then it worked. Not sure how or why, but it took care of the problem. Hope this helps.


I tried deleting and reinstating the ROW ID field. It cleared all the previous automatically favorited entries.

But now when I try to favorite those same ones, it doesn’t allow me to favorite. But other entries can be favorited.

So old entries where you have cleared the rowID doesn’t let you favorite it anymore? What’s the behaviour? The “heart” just doesn’t turn to a “filled” state?

Before clearing the rowID for the first time, there are 3 entries that always get favorited automatically. Even when i unfavorite them, they favorite themselves again.

I also noticed if i delete one of the problematic entries, it just automatically favorites some other entry, which gives me an indication either im doing something wrong, or it’s a bug?

After clearing the rowID and then repopulating it again. Everything is cleared. But now the same 3 problematic entries, I am unable to favorite them. When I click on the heart to favorite it, within 5 seconds it becomes unfilled again.

I think there’s a bug somewhere in there if it “favorites automatically”. I believe favorites are tied to the rowID so probably that is the source of the problem.

Can you try duplicating the app and see if the problem persists?

Duplicating it doesn’t work.

But creating a new one seems to do the trick. I must have messed up something along the line.

Thanks ThinhDinh & jspellos for your help!


1 Like