Error trying to create a new Pages product

I am trying to create a Pages project. I select Google Sheets (all my other projects are google sheets or glide tables) and I get these series of screens where the last one never leaves the screen until I refresh the browser. What am I missing about authorization for google sheets? I am currently editing another project which is based on Sheets without any issues.


Try emptying your browser cache and deleting all Glide & Google related cookies.

I used my MS OneDrive account and got access to the tables in Excel (they are all text fields) and added them to the Page’s project.

I added a template field to the first table to get First-Last Name - worked fine.

I added an image field to the table and got this message saying it was a USC - interesting.

I then tried to add an image to the record using an image picker component on the edit form and got this red message.

When I click on the component and select ‘Choose an image’ to add a photo it does not allow me to upload an image. I must be missing a setting or something?




You seem to have gone off on a tangent with a completely separate issue. Can I assume that the previous issue is resolved?

I’ve heard that this happens with AirTable, perhaps it also happens with Excel (I don’t use either).
My understanding is that if you need non-computed columns that are not user specific, then they need to be created in the data source (AirTable/Excel), rather than Glide.

So maybe that’s what you need to do. (But please take what I said with a grain of salt, because as I mentioned I don’t use Excel).

Yes, it does indeed. You must add all new fields on the Excel side.

I got around the weird authentication problem by not using Google instead using Microsoft OneDrive (which didn’t have authentication problems) to import the Excel table/sheets. But with problems adding fields to tables.

So I got around the OneDrive/Excel problem by taking all the Excel sheets and saving them as individual files and importing them INTO Glide tables.

Glide is happy (no more ‘red’ when adding a new image field to table) - but images still cannot be uploaded in the edit form.

I even went to the Things/Categories/Users Glide Pages example and tried to edit a ‘Thing’ by uploading a new image…no luck.

So I guess I don’t know how to upload an image using the image picker in Pages