Enabling Visibility Conditions & User Profiles NOT Working

Hey There,
I am new to Glide and am trying to make my first app. I have followed several tutorials in the library and have gotten closer to what I want. However, I seem to be stuck. I want to enable visibility conditions so that I can limit what each user sees. When I try to do this it tells me I need to configure user profiles. So then I went to that tutorial and followed it: I have set up a User Profiles Tab (with the email tab set to Row Owner), and I have set my apps privacy to public with email, then it tells me that I need to click on my app’s menu and click ‘Sign In’. Here is the tutorial: https://docs.glideapps.com/all/reference/security-and-per-user-data/user-profiles

BUT when I click on my app’s menu, I don’t see a Sign In button:

Is this only a feature for paid Glide apps or is it possible to do this with the free version?

1 Like

In this menu, you gotta add a sheet as your User Profile, and it will allow to add visibility in tabs

In the editor, you are always signed in to the app. You just need to click on your email address or profile image at the top of the menu and it will open the sign in screen. On the right you will see the options to set your user profile sheet.

I clicked on my email address and this is what came up:

There are still no options that let me set one of my sheets as a User Profile…

@dojosourcejeff On the left side of screen click the layouts view :+1:

1 Like

1st

By default, no user profile table is set. To set one, create a new table with columns for Name, Email, and Photo. You can add more later, depending on the properties of your users.

Next, open your app’s menu and click ‘Sign In’. The right panel will now show User Profile settings. Choose the table with your users and connect the Name Email and Image to the correct columns.

2nd

You can add conditions in the Features section of each tab

3 Likes

Thank You Everyone! I was not in the Layout tab and so User Profiles was not showing up for me on the right.

3 Likes

You’re not the first one that’s been caught by this, and I’m sure you won’t be the last :joy:

1 Like

Guilty :wave:

1 Like