EDATE in Excel formula is not working

I feel that Edate is not working properly in the excel formula

Excel Formula Column

3 Likes

I haven’t tried it, but you might need to do the following:

  1. Format your date in short form
  2. Use a template column to wrap it in quotes
  3. Use the template column as A1 instead of the date column

Nope its not working

Hm…this is the only way I got it working…might be more trouble than it’s worth.

2 Likes

Thanks @Yasin_Hassanien for creating a topic for this issue!

I thought I’m the only person who gets this error! :sweat_smile: Mark ( @Mark ) are you able to help here? :upside_down_face:

Thank you! We’ll look at it.

2 Likes

So I managed to run formulas in excel by creating a column template and replacing the values in it, mostly the issue was because the I can’t add Double Quotations in the Excel formula like the image below

But the workaround is to prepare the excel formula in a template column to ensure that all the text is exactly brought from the backend properly to send it to the formula column as below

Then map it to the excel formula column will work eventually

@Robert_Petitto Your method works but alot of columns and math was getting my table messed up so I tried my best to the shorter solution as I mentioned EDATE in Excel formula is not working - #7 by Yasin_Hassanien

I’m not totally following this thread, so maybe I’m talking out of my rear end, but just quickly reading your post about double quotes not working…could it be that you need to escape your double quotes to make them work? In the code world, when you are working with strings of text, you typically wrap them in double quotes to indicate the beginning and end of the string, but if you need to insert a double quote in the middle of that string, then you can run into issues because an inserted double quote will mark the end of a text string prematurely. To avoid this, what we do is ‘Escape’ the double quotes by insert two double quotes together. “” instead of ". The code will translate that into a single double quote, but inside of the text string that is already wrapped in double quotes. Google ‘character escaping’ to get a better explanation. I wonder if that’s maybe the case here. So anywhere you need a double quote, you will actually have to type two double quotes. Maybe this is something glide needs to address in their new Excel plugin.

2 Likes