Displaying Inline List on Page Load

I am back struggling with my inline list. I had the filters working properly but it wasn’t set to display when filters were empty. So I tried to add a visibility condition on my inline list to display when both filters were empty but I may have created a bigger problem. Now one of my filters isn’t working. I believe the problem lays in the configuration of the inline list and filters. Not in the data. I can send screenshots of both if necessary. Here are some for now that should help…Thanks!!

Also, when I click the first filter, it makes the list blank now for some reason…


Not sure how your filtering is currently setup, but this is how I would do it:

  • create two single value columns that apply your choice selections to every data row
  • then create an if-then-else column:
    – If Single Value Professional is empty, then null (leave empty)
    – If Single Value State is empty, then null
    – If Single Value Professional is Professional, then null
    – If Single Value State is State, then null
    – Else true

The above will give you a “reverse” filter. That is, those rows that return true are the ones that do NOT match your selections. And it will handle the case where either or both of your selections are empty.

So the filter on your Inline List becomes “where if-then-else is not checked”

1 Like

Currently, I have a two tables: one for each of the filter choices. Then, I have a table for the selected option in the filter. (Screenshot below)

I also have columns in my tables with the list of people and details for listing (master sheet).

oh… you’re the guy from last week with the multi-selects, yes? :slight_smile:

Okay… just looking at your screenshots, I think all you need to do is add an extra condition to each of your if-then-else columns (if-show-seller, if-show-state)

So it would be something like:

  • If sv-selected-state is empty, then true

And make that the very first condition.
Then do the same for the other one.

And that should do the trick for you, I think.

Yes that is me sir. Hello again lol. Thanks for more of your time.

This is how my SV are currently configured…

Seems I already have that configuration. When you go to the live version of the app, clicking either “Investment” or “Tax & Accounting” results in the list being blank

Also, the app works fine on the glide backend but doesn’t on the live version…

I’m trying to understand what the purpose of that Find Duplicates column is, and how it fits into the if-then-else logic.

Is this based off the sample App that @Jeff_Hager created for you?

Answering my own question, it looks like it is based on Jeff’s sample, but you’ve added a second filter.

So if I’m reading this correctly, I think all you need to do is change the filter on your Inline List to use an OR instead of AND.

Screen Shot 2022-09-14 at 12.16.30 PM

I don’t think it has purpose. It was based off of what Jeff created, yes. I tried deleted the Find Duplicate column and Find Duplicate condition in a copy but then the filter stopped working.

When I change it to OR the inline lists doesn’t change when selected.

I have a copy of Jeff’s sample App. Let me modify that to use two filters instead of one.
Will be quicker than going back and forth.

Just give me a little while.

Super grateful for you Darren!!

Here you go…

I should point out that there is a potential gotcha with the “is included in” approach that I used there for the State filter. For example, if you had one state called Texas, and another called South Texas, then both would match if you filtered by South Texas.

I don’t think that’s an issue here, but to make it more robust I would probably create a separate States table, and then use a StateID (RowID) as the filter.

1 Like

Alright, as I’m going through the first thing I noticed was that I have 2 split array columns in the Tab table while you had one.

Yes, for the method I used for the State filtering, it’s not necessary to convert the Selected State column to an array.

It seems I am close but if I select “Tax & Accounting” (second option of my first filter) and also select a few states, there are still some results coming up that Are Not “Tax & Accounting” and Are in the selected state. Below is an example. The middle box is showing california because that option is selected in the filter but then it should go away when “Tax & Accounting” is selected.

It’s hard to tell because I can’t see the rest of the columns, but from what you show there only the last row is matching. Is that not correct?

Here is the left half.

So, exactly, that is not right. The listing showing is an “Investment” person and should not be appearing

What are you using as the filter on your inline list?

Above is my choice configuration for Types