Difficulties with images and

I am starting my own first dummy app just to get the lay of the land… and I am having a number of issues I didnt expect.

  1. I can choose an image from the stock gallery, but I have tried a number of ways to upload, drag n drop and other way to get my own images into the app with no go. I also can’t delete the images I chose from the stock gallery.

  2. Glide created an column in my glide spreadsheet that I did not request. Unlike the other columns glide will not allow me to remove that automatically created column

  3. I created a “form”, and some of the parts of the form does not work - 1 text entry will not write “description” on top of the entry, even though I have it entered the same spot as the other text entries. I also cannot upload images on my form, the same as the image issues in the spreadsheet. I took away “required” from the image entry because it wasn’t working - but when I click “add” on the form I get absolutely nothing. No response to the add, the page just stays the same.

Please advice. THank you,

Do you mean from the built in Unsplash gallery?

There are several ways to upload an image into glide. First you should know that glide only stores the url for the image inside the table cell. The actual image is stored elsewhere.

  • One way is to use an image picker component. An image picker on a app screen would allow a user to upload an image.
  • Another way is within the data editor. If an image column has it’s type set to Text, then you will see the url for that image. If the column type is set to Image, then you will see the image. When it’s an image type column, then you should be able to click on the cell to see a larger version of the image. You should also see an edit icon. Clicking on that should open up options to let you drag and drop an image file to upload it, or enter a url for an image hosted elsewhere, or choose an image from the Unsplash gallery.

If you are trying to upload an image somewhere else, or having a particular problem, it would help to see a screenshot showing where you are having the problem.

Glide shouldn’t automatically add a column. It’s likely that you may have clicked on the Add Column button. You should be able to delete computed columns with no issues, and you should be able to delete basic columns in glide tables without issues. But, if your data is connected to an external database, such as google sheets, then you will have to go to the google sheet to delete the column.

Again, a screenshot may be useful here.

I’m not sure I follow the problems here. If you can provide screenshots, or better yet, aLoom video showcasing the problems, then we might be able to see something that might be misconfigured.


Hey Jeff,

Thanks for the reply - the problem is that I have watched the tutorials, and Glide is not acting as the tutorials tell me it should.

I go into the column for images, and I have chosen images from unsplash - no problem. But, I go into “edit” the image, because I never wanted an unsplash photo, I only used that as a place holder because uploading wasn’t happening.

I get the screen to choose the image from my computer - click on “upload” and choose the image I really want from my computer - and “Nothing”. By “nothing” I mean that the software complete ignores my chosen image and go back to the unsplash image. Before I chose the unsplash images, I simply got no image, no error message, no reaction, I chose unsplash because image upload wasn’t working. Now, I have an unsplash photo - and I am trying to replace that with the photo I want from my computer - nothing changes. I have tried different screens, clicking upload and choosing the image or drag n drop - nothing!

No matter how that other column got added, I click the little drop down box, and there is no option to “delete”. There is a option to “edit”, but I dont want to edit, I want to delete. All the other columns have an option to “delete”. I dont know where the column came from, I could certainly have made a mistake… but I can’t delete it, the option is simply not there like it is on the other columns.

Finally, on the actual tab page, I created an “inline” form. Most of the fields act the way the tutorials say it should - nice. Except one text entry that looks all wrong, and no matter how I try to make the exact same changes as I did on the other text boxes, it will not input what I type. I have compared all the fields to what I did with the other entries - and it doesn’t do the same thing.

Also, on this inline form I have added in an image option - and it refuses to upload images from my computer; much the same way as it doesnt choose the image from my computer in the spreadsheet. So, I unchecked “required”, because I wanted to still try to create an entry, I clicked on “add”, and the screen is just stuck. No error message, just no movement. Also, “Add” is not a clickable link.

I am on a fully updated and fully protected windows 10 computer. My next step is going to try to delete cache.

I am following along on both glide classes and Tara Reed’s classes, and the software is not acting the way I am told it should - and not acting consistent with similar entries.

1 Like

OK, that does sound odd. Once I get to a computer, I’ll play around and see if I can reproduce any of those issues. In the meantime, check if you have any browser extensions that may be interfering. Also what browser are you using?

And if you have time, some screenshots really do help. A lot of times we can see things that you may be missing, or didn’t even think would be an issue. Pictures are very telling.

If you don’t see an option to delete a column, that usually means that the table is connected to an external data source. eg a Google or Excel spreadsheet or AirTable base. Is that the case with this one?
If it is, then you have to go to that external source and delete it. That is the only way.

For your other issues, as Jeff mentioned - some screen shots would be really useful.


Thanks Jeff, and sorry it took a while to get back to you. I am going to do a loom video and send to tech support right now. I can also see if I can post it here.

I am in chrome, and not in the habit of adding a lot of extensions. I do think I should probably empty cache at this point, and will do that now.

THank you,

Hey Darren,

No, I am using the glide tables at this time. I will see if I can upload the loom video shortly


Thank you Jeff and Darren,

Thank you Santiago,

I really appreciate your offer to help, I know I am not yet a paying customer. I did do a loom video, but I tried to do it multiple times, and the sound is terrible. Before I started the loom video this time I did empty cache, and that made a small difference, but I still have trouble.

What I am showing you:

  1. I can’t delete the column called “Favorites”, I also do not know how that column even happened. I am working in glide tables

  2. I cant seem to add an image from my own computer. I am showing you how I try 3 different ways - no dice

  3. The add a restaurant feature works a little better - it doesnt disappear into the ether, after emptying cache. Yet, I am unable to upload an image, the add puts in two columns with the same information, and when I click on it on the restaurants tab it shows as entirely empty, even though the info is in the table.

THank you so much for your assistance

Malene Comes

Yeah, there was no sound at all in your video,but I think I was able to follow along.

The favorites column is a built in column that is required if you use the favorites functionality in your app. Usually it’s hidden, but I believe if you add a favorites component on a detail screen, enable the favorites button on your inline list, or enable the favorites bar when your screen is a list style view instead of a details style view. That is totally normal, and I’m guessing you did something with favorites at one point to cause the column to expose itself. I wouldn’t worry about it. It has a purpose and is not as random as you think.

  • First of all, I’m not sure why you can’t upload by using the the windows prompt to select a file and click open. To me that’s a windows or chrome issue if that’s now working. When I try it, it works for me.
  • The second thing I noticed is that when you attempted to drag and drop your image into the cell, it just opened the image. This is normal because you didn’t drag and drop into an area that allowed you to drag and drop. You should have to first get back to the prompt by clicking the edit pencil, and there you can choose between upload/url/stock images. In that prompt is where you can drag and drop your image.
  • I also noticed that you attempted to drag and drop the image directly onto the inline list item. That should technically work…just not on a Card style layout. I was able to use the drag and drop method on List and Tile Layouts, but not Cards.
  • The failed upload using the image picker is weird. I would still lean towards a something specific to your computer. Maybe try a different browser, or another computer, or a different network. There must be something that is preventing you from uploading, but I doubt it’s something on Glide’s end. If it was, there would be a lot of people saying something about it not working.

First of all, don’t add an Add Row function to a form. Add Forms and Forms are designed to add rows. That’s is their sole purpose. I’ve seen many people add an Add Row action in their On Submit action and then wonder why they have duplicate rows. Adding an Add Row to something that is designed to Add a row is redundant. The only time you should be using the On Submit Action is when you want to do something AFTER you have added a row. It’s already adding a row for you when you click on Add/Submit. Get rid of that action and it should fix a lot of issues.

Well, I see 3 items in your list with images, 1 item that corresponds with your blank row, and 2 items that may appear empty but actually don’t have images. I didn’t see you scroll down on your list in the app, but I assume everything is there, so I’m not sure I follow what you mean when you say it’s empty. What 's empty?

Just going off your 3 questions and the video, with no sound. Sorry if I missed something. If I did, let me know.


I had that problem before and I think Krisp solved my problem pretty well. Hope it helps when recording in the future.


THanks Jeff, Worked through a lot of stuff today. After removing the “add a row”, the favorites column also disappeared. I got the add a restaurant to work - except the images thing, but tech support is logging into my account to fix that later this week. I do think the software is not acting as it should - and since I am currently in an app building class, I know several of my peers are having issues with this as well.

I even managed to add a “relations” column and get that to work. So, I am pretty thrilled and learning a ton right now. Thanks for your help