Data from Glide Table not syncing with component data?


I created a relationship field from my “posts” table to “users” table. Despite the relationship working correctly in Glide Tables, the relationship data does not show up in the component data section. I have attached images below for reference. Not sure what I am doing wrong.



Ok it seems like I might have fixed it by accident. Seems having a row owner for the users table causes this.

Hi @willem, as I understand, you are doing things right.

The relation column’s visual representation might be a bit misleading for newbies. It serves as a way to show you that there’s actual rows that were returned based on your configurations.

Glide might grab a random column from the destination sheet to display, and in your 2nd screenshot, it seems like it was grabbing a column without a value.

If Glide doesn’t find a row to return, it will not display any grey shapes in there.

Thank you for the response! This was definitely a confusing one. Glad to have a better understanding of Glide’s relationships now. It seems that removing row owners form the users table has solved the issue.

Or Glide might have just grabbed a column with an actual value :wink:

Let’s say we can see that as a pathway to the returned row instead of an actual value. For actual values returned from a relation, you would want to use an additional lookup column.

Let us know if you have any more questions.