Could not get Average or Sum in Rollup column

I have the JSON column to return a value between 1 and 9. Ok, I presume it might be considered text, so I have used another MATH column and converted it to Int using the T function. I could see the decimals, so I presume it is a number.
Then, I used another table relationship to select the transactions per month/year. I used the look-up function and can see the values that I need. However, I could not use the Rollup function on this array to give me the AVERAGE.
I tried using QURY on the Relationship, still can only see the COUNTs I can only see Count and Count Unique. What Am I doing wrong here?

If you’re only seeing count and count unique something isn’t a number. Could we see a screenshot of your setup?

I have uploaded a few screenshots to illustrate the example. I agree it does not seem to recognise a number, but at the same time, why does it add decimals, then?

It might be because you are trying to use the Lookup column in your Rollup. You shouldn’t need the Lookup column, as a Rollup can work directly through the relation.

True, I tried both ways - the same effect :frowning:

Could it be a bug?

I agree with what Jeff said but also you need to do something in the configuration of the math column… to force it to a number



1 Like

Super! this worked! How silly of me not to think about this small thing
Thank you, Eric

1 Like

Happy to help! Thanks for the screens :sunglasses:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.