Convert a URL to an image

How do I convert this URL to an image in Glide.?

The url is the image. An image column in Glide is nothing more than a stored url that is nicely rendered as an image. It’s still the url underneath. If you want to see the image in the data editor, you can change the column type to Image. Otherwise, it doesn’t matter if a column shows an image or a url…you can still display it with an image component or any other component that displays an image.

The link you provided cannot be shared as it does not have permission.


There is nothing to “generate”. Glide does the same thing as jotform. The column stores a url, but if the column is configured as an image column, then it shows the image instead of the url. If you change the ‘Self Image Upload’ column to an Image data type by editing the column, it should display the image.

Even if you did nothing in the data editor and left it as a text column type, you can still create an image component and refer it to that text based url. At the end of the day, Glide is only looking for the url. It’s your device that actually downloads the image based on that url. Glide does not store any binary data in the table.

Now if no image is rendering, then consider what @Himaladin pointed out. Your urls don’t appear to have publicly accessible images. That may be the actual problem you are trying to solve by getting the image to “generate”, but in reality the actual problem is that the image is not public.


It must be a problem with Jotform. When I the column to an image the Urls disappear. But when I double-click on a cell the actual pops up.

When we visit the url in your first post, we get the 404 error. It may be working for you if you are signed into your jotform account, but the rest of us aren’t, so we don’t have any kind of access to the image.

I know google drive (not recommended hosting media) allows you to set permissions of files to make the public or private. I don’t know if jotform has the same option though.

1 Like