Carousel works in one tab, but not the other

I have carousels on two tabs, in one it works fine and all images display properly. In the other, set up identically, it doesn’t.

Things I’ve tried:

  • Redo the tab from scratch
  • Redo the sheet.

Not sure if related, but overnight I had an email notification:

Issue Description

Glide cannot load data from your spreadsheet. The cause of this is that your spreadsheet has become incompatible with your app. Open the app in Glide, click “Reload sheet” and review the issues.

There doesn’t appear to be anything wrong with the sheet or app. All components load properly.

Any ideas?

Have you tried reloading the sheet?
Delete all empty rows and columns.

Hi @eltintero - I’ve reloaded a number of times since, as I’ve been working on additions. No problem with the app. There are no empty rows or columns in that sheet. There are empty cells for products that don’t have 3 images, but that hasn’t created an issue in the past. Some have 1, some have 2, etc.

What exactly is not working?

Only image 1 displays for each product, not Image 2 or 3 for those that have them. So, carousel is not working properly.

Are you selecting the ‘Image’ array column as opposed to the ‘Image 1’ column?

Yup. Could be a bug I suppose.

If you have any screenshots of your data tab and component settings, it might help.

I copied all content from the sheet, then wiped it clean, and pasted the same content again. Didn’t make any modifications to columns. It now works.