Call API auto refresh not working

When I set the auto-refresh to a certain timeframe it doesn’t work.
The API refreshes if I force it with a CTA where I manually refresh it every time, but the automated refresh doesn’t seem to work.
Did anyone else encounter this issue? Or am I typing the timeframe wrong?

Not sure if this is the case for you, but this is what it says in the documentation.

Yes, I initially thought about that as well, but I’m not sure to be honest because this API is for the price of Bitcoin, which changes every second (some event that makes it clear that data needs to be updated), so it should get updated, but for some reason, it doesn’t. I don’t know… I thought maybe I am not formating the timeframe correctly in minutes or seconds. Or it’s in fact a bug

Yeah, I’m not sure. My only thought is that maybe data needs to change in that row to trigger the refresh, or maybe Glide doesn’t like a refresh rate of 1 minute since that is pretty aggressive and will eat through your updates very quickly.

My only thought is to add a dummy query parameter that pulls a timestamp, but you need to be very careful that your timestamp doesn’t change every 10 seconds or every minute for that matter. It would have to be a value that doesn’t change too often, but is automatically calculated based on current time. Maybe every 10 or 15 minutes. Overall, Glide may frown on CallAPI being ran excessively, so I’m not saying it’s a good idea or recommended, but it is an idea.

A math columns with a formula like this would give you a value that changes once every 10 minutes and you could maybe plug that into the query parameters.



This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.