Calendar reminder

Hi,
what is best way to set an event reminder from Glide to a calender, eg Google calender?

Thanks

To be clear, you can’t set it for your user. Best case is you provide them a button to do so with a service like Agical.

Thanks Thinh…I did come across your recommendation when searching this community, but could not really figure out how to do it. First time I am looking at this. Could you provide more example of the setup please.

https://agical-glide-yes-code.thinhdinh.repl.co

This is not the complete version where I test all possible errors, but plug that link in an experimental code column and you can find the parameters needed.

Please also take into account your starting and ending times must be formatted correctly (ISO).

thanks Thinh. will try it

1 Like

Hi @ThinhDinh,

Agical works nicely. However, I am using Glide Table and the date/time is 9/16/2021, 7:00:00 AM
Is there a mathematical formula we can use to convert to ISO 20210916T07:00:00

Thanks

I haven’t figured out that part, when I have time tomorrow I will try with XC and let you know if I find something.

Something like this?

https://mcdarren.github.io/glide-to-iso-string/

Note that this will actually return the time in UTC, adjusting for the users timezone. ie. in my case I am UTC+8, so the returned times are 8 hours earlier. If you don’t want that adjustment made, you could use a math column to take the UTC offset into account before passing to the YC column.

thanks @Darren_Murphy, exactly what is needed.

I just used 24 columns in Glide Table splitting, extracting and putting it back…also using IF-Then-Else

I wonder which method is faster.

I did some testing. Attached is the image of 3 sets of time

  1. 1st set - manually key in the ISO time → works as expected, able to link to GCAL with correct date & time

  2. 2nd set - I did calculations inside Glide Table (GT) using about 30 columns to split, extract, calculate and then put together inside a template. The display looks good. When I use this column in your code, the GCAL date is always 1, Jan 1970, 7.30am for both start end end. I tried to display text, it shows --AMT. This means that for some reason the value is not being passed properly

  3. 3rd set - using @Darren_Murphy formula. The value is correct (have not adjusted for timezone). The display looks good. When I use this column in your code, the GCAL date is always 1, Jan 1970, 7.30am for both start end end. I tried to display text, it shows correct value. However, when I do the select during setup of the text display, the value does not exist. This means that for some reason the value is not being passed properly.

Appreciate your comments.
Thanks

The difference seems to be that when you manually type it in, you aren’t using any separators. I can quite easily tweak the YC to produce that same format. Just give me a little while and I’ll do that for you.

@Mns_Glide give that a try now

1 Like

thanks @Darren_Murphy . It does not help. Just to confirm, I also add in the “-” for the one I manually key-in. It works. So “-” or no “-” is both acceptable.

I think it has something to do with the time it takes to pass the parameter over. As I mentioned before

Okay - what about the milliseconds part at the end and the Z suffix, could that be causing the problem?

Doesn’t help. Have tested changing time key-in manually to with microseconds or with Z…all working well. The one I calculated on GT was modified to add as well but NOT working. If you see the attached photo where I wanted to display the values in the APP, you can see clearly
1st set manually key-in shows the value
2nd set where I do internal calculation shows “AMTZ”
3rd set using your formula have no values yet (I guess it needs to retrieve from calculation?)

I am narrowing it down to timing of populating the value before GCAL is called as main factor.
Your thoughts?
ISOtime1

yeah sorry, I’ve never used Agical so I’m not sure. At this point, I’m thinking @ThinhDinh will probably have a better idea.

1 Like

thanks, The strange thing is - why I cannot display inside the app, the values in my template column. I can see it in GT, but when I do a text display, it comes out as AMT.

Just an update @ThinhDinh and @Darren_Murphy

  1. Using both of your codes together are working well
  2. Using construct URL and @Darren_Murphy 's conversion is working well

@Darren_Murphy , the Timezone UTC+8 is right time for me also. Any chance of you changing this in the future that may affect my app?
Thanks

I have no immediate use for it myself, so it’s unlikely that I’ll change it in the near future.
But if you want to be safe, you are welcome to clone the repo:

git@github.com:mcdarren/glide-to-iso-string.git

or

thanks…now need to go and learn how to clone

haha, I’ve been a Github user for many years, so wasn’t really comfortable using replit.

To get these YC columns up and running using Github:

  • Sign up for a Github account
  • Clone the repo
  • Publish it as a “page”

To do that last step, you need to navigate to the repo, then go to Settings → Pages

Everything you need to know about Github Pages:

2 Likes