Bought a template from template store an received an error, no money, no template

Hi. I ask this here to know if someone experimented the same.
I bought some minutes ago a template from the template store, i payed $49.99, but then a message appeared saying something like “Could not copy template” or something like this. In my bank account appears the charge of $49.99, but i haven’t got the template… I haven’t received any email of my purchase.

I asked glide support but no answer yet. @david

Have you tried to download the template again?

Have you contacted Glide Support?

Yes @Jeff_Hager , i’m trying to download again but same result. And yes, I contacted with support team but no response yet.
Captura de pantalla 2021-09-23 a las 18.04.04

Which template is it, or who is the author if it?

This template @Jeff_Hager

@rayo would you have any thoughts on what could be happening?

1 Like

Hi Jeff, a few other purchased the template and everything went fine. This must be a Glide Bug. I’l try to look into it. Meanwhile anyone we can tag here that might know?

Thanks for the reply @rayo. Let’s wait Glide’s answer then…

Just to confirm, his payment has been received.

1 Like

I have the same problem. I bought a template and I did something and it disappeared, and I cant get it back, without paying for it again.

We are investigating this. Thanks for your patience!

@Lena_H-K you shouldn’t be charged again. Have you tried to download the template again?


When you purchase a Template, Glide records this fact and links it to the folder you initially selected. This record of purchase allows you to “purchase”/download the Template again at no charge. Therefore, when you try downloading the Template again, you do have to download it into the same folder you originally selected to add the Template to. Also, note that it will show the price but you will not be charged again.


Ok good. Thanks!

Not my case. Unable to download the template to the folder i selected when i purchased the template yesterday.


Please, log out of Glide. Then, open Gmail or GDrive. After that open Glide, and try to download the template.

Please, make sure you select the right team.

Let us know how this goes.

You must sign in with Google to copy a template that uses a Google Sheet. Make sure you have signed in this way.

1 Like

Glide support team say to me the same as you and I have answered them the same. I Tried it 10 times or more, with different browsers, incognito mode, shut down my pc different times, and nothing worked…

Of course (i’m not idiot), i’m choosing the team (my Glide main folder / “My apps” folder) I used to buy the template, if I choose another team it ask me to pay again. I tried it a lot of times… Is the main folder the error?

Of course I sign in with my Google account, as always.

I Logged out from my google account, logged out from glide account, cleaned cookies, restarted my mac, signed in to google account, signed in to glide account, and not working. I tried it a lot of times…

More suggestions…? :sweat:


What is Glide seeing from the backend… what is triggering this error for this user? is it possible to track from Glide side what is happening that is not causing him to copy this app?

@nosehms The Ticket you submitted has been escalated to our Engineers. You will be updated on the status within our Ticketing system. The issue seems unique to this particular Template.