Be careful with GEOAPIFY - it will spent all of 3000 free credits in minutes - not even in hours((

Hello guys!
I did the case after beatiful Robert’s video about Address autocomplete by Fetchcolumn & Geoapify, but unfirtunately it seems this API works just a few times. I made everything described, and even start to test.
But after a few success attempts it started to return nothing to Glide( What’s a secret? Is it bag from API or from Glide FetchColumn?
I checked by Best JSON Viewer and JSON Beautifier Online, and there are:
statusCode : 401
error : Unauthorized
message : Invalid apiKey
(( But the apiKey is correct.
I made another account & apiKey at Geoapify, but it was not helps.
What’s wrong?

Hi @Alexey_Baranov1,

Check if there are spaces in your API Key. And run this in your browser to see what you get!

Just tried and I got the results!

And also try creating a new API Key by clicking this icon and adding that in the column!

Thank you

P.S: I think you wouldn’t need a Template column that gets the entered address that stored in the Users table because in you construct url column you already added that as User Profile > Address. And you don’t want to add https here :

because Glide adds that for you automatically! :muscle:

1 Like

Thank you very much, @Dilon_Perera! :pray:
Am running to check out your ideas, will be back soon. :man_biking:

The Template column that gets the entered address stored in the Users table i put there just to show here it’s not empty.

1 Like

I’ve found a couse. almost root)

Seems like when you establish URL Construct Column, then FetchJSON Column - each of it on the each Row generates a Request to the API. So while i just combine the columns and try to test, the limit of Credits becomes to 3000 in a minutes, even not in a hour or in a day :joy: :grimacing:
Seems this API is not good enough idea to use even for a few request in a day, becouse all of it will be loosen in minutes)))


This is one of the problems when an “autocomplete” feature is used with API requests: too many requests will be fired while the address is written completely or partially :woozy_face:.

E.g.: If an address has 10 words (almost 70-80 characters), you will fire at least 5 API requests when you have just typed 8-12 characters and surely, the API still hasn’t found the right address!.
The best option is to create a button to fire an API call once the user has written full address and test it.



Hola & thank you for your suggestion, Gvalero! :wave:
Looks like this is only way for free API plan. But even when you pay - it still too dummy to pay for each click)) So we need a button to call an API.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.