Audio not playing in podcast app, despite .mp3 file

All the .mp3 files are organized correctly in sheets, yet I’m unable to play any audio on Mac or phone. Any suggestions, please?

What are the sizes of the audio files? Where are they located? Give us an example of one of the audio file links?

Hi George, each is about 2 hours in length (not sure actual size), and look like: http://feedproxy.google.com/~r/twist-audio/~5/4wHzcFKk7fY/ANGEL-E033.mp3

Nothing wrong with the mp3. I got it to play in an app I wrote without issue. You are using an Audio Component correct? I just used your app and the audios I selected seem to play fine.

yes, it worked before but now it doesn’t. very strange

Not playing for me on iPhone 7+ Chrome or Safari

What is the mp3 link for this specific audio file? The one called: e1017 open office hours live. I tested the link you send above http://feedproxy.google.com/~r/twist-audio/~5/4wHzcFKk7fY/ANGEL-E033.mp3 and it works, but now I see that it works in your app as well. Send me one that doesn’t work.

so I made no changes but now they all seem to be working fine. Weird. I don’t know what caused the glitch.Thanks for the assistance

1 Like

looks like i spoke to soon! Tried it on mobile devices and it’s no bueno. Not when played in a browser, or saved to homescreen :frowning: https://twist.glideapp.io/

If you copy and paste one of you mp3 links into your mobile phone browser does it play?

the mp3 works just fine when pasted on mobile browser. I can even exit the browser and it still plays…

Try putting https instead of http on the url.

1 Like

As a diagnostic step, temporarily add a text component to your app that shows the actual link that your app is using in that audio component. Just to make sure it is in fact pointing to the link of the audio that you expect.

thanks for the info. i did this and now it works on desktop, but not on mobile. so at least half the problem is solved!

I had a similar problem when I tested a small version of my choir app in December 2019. I received several error messages that stated something to the effect of exceeding quota. A bit of digging suggested that audio downloads were limited to several per day (I think it was 5 or something; can’t remember) and the files would reset within 24 hours. I’m a bit worried about this because I will be launching the full version of the app very soon and I have a group of 65 people who would be using the app to access the choir’s playlists. I am very tempted to move all of my audio files to Dropbox (I can do this, right?) just to avoid any future issues with this part. If there is a better solution to this problem, I’m all ears.

@Jason @Mark Is there a size limit on the audio files that can play in the audio component? I tried one of @Ramsey 's audio files in an app http://feedproxy.google.com/~r/twist-audio/~5/4wHzcFKk7fY/ANGEL-E033.mp3 and at first it would not play in the development environment, then it did after a few spreadsheet reloads. I then tried to play it in the app on my iPhone and it would not play. I suspect the size of the file is the issue but am not sure. It is 65.1 MB in size.