Apps not Duplicating


I have been trying to duplicate two of my apps this evening. After clicking “Duplicate App”, I just get the oscillating rectangles, and nothing happens. I return to the “Apps” screen with all my apps, and the new app appears at the bottom of the list with the word “Loading”. When I click on that app, I just get the oscillating rectangles.

Any else experiencing this or is it just me?


:wave: Happened to me twice this evening. They never finished loading but I was able to delete them…

Did you get them to eventually duplicate?

I can confirm this is happening to me too…never duplicated.

The same is happening to me

Recategorised as a bug.

@SantiagoPerez - seems to be widespread, are support aware of this?

Same here. Now working since last evening

Thanks @Darren_Murphy!!

I can reproduce. Passing this on to the team.

1 Like

Same issue for me and a couple of customers too.

Requesting an urgent fix for this as it’s a huge blocker!

We are aware of the issue. It is too late for a hotfix today but we will get this fixed ASAP.

1 Like

Any timeline by when we can expect this. Will plan the same internally accordingly.

No promises but I would be shocked if it’s not fixed tomorrow


Thought I was going crazy or doing something wrong. Glad it wasn’t just me.

This has been fixed!

1 Like

Awesome, Thanks for the Update Santiago!

Hi Santiago,
Still not working for me. I need to duplicate the Google Sheet (not use the same Google Sheet). I get an error that the app cannot be duplicated because the Google Sheet is too complicated. I have tried all my apps including one with almost no data. Same error.
Don’t know if I should start a ticket.
Attached is the error message.

Hi All,

I had to sign out and back into Glide, and it now works.

Appreciate the help from the team.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.