Airtable & Excel Early Adopters Wanted


As Glide import numeric computed Airtable fields as a Text field It’s not possible to create a Rollup Glide column with Sum totals, only shows Count option.

and currency € format

Captura de pantalla 2022-01-29 a las 13.07.47

@darder That issue will be fixed next week on Wednesday, at least for new columns that you add.

You should also be able to just change the type of the column to number, or at least you will be next week if not now.


Yep. Perfect. I tried it and it is now possible to change Airtable computed numeric fields to number format in Glide, and also perform Rollups. My Airtable data look gorgeous in Glide. :yum:

I can’t add uniquely related fields to a Glide collection. I guess this will be possible when Glide “inherits” Airtable relationships.

1 Like

I tried to connect my airtable base this morning everything worked fine until I clicked on the Create App button. After clicking create app, this screenshot below appears and times out.

Have the same issue, I believe it’ll be fixed next week according to Mark

Sorry, what do you mean by “uniquely related fields”?

What’s the issue you’re having?

If it’s possible, could you invite me to your Airtable base?

What Airtable permission level would you need to identify the problem?

Just read permission.

I’ll try to explain myself better:

A Short description:

Some Airtable linked columns do not show any content in Glide in the “one” column of the related table. Glide LookUp columns for those “empty” relations doesn’t work as well.

A detailed description:


This is the expense relation which have just one “proveedor”

Captura de pantalla 2022-01-29 a las 20.43.20

And this is what I see in Glide.

Yeah, it’s empty.

Close to this related to “proveedor” field I have created a Lookup formula column in Airtable to show the related “proveedor” and then, yes, Glide shows it.

I’n not sure if this is due to the 100 rows limitation in Glide as I’m using a personal version for this test, but all “one side” of the relations columns appears “in some cases” empty in some tables

By the way, relationships from one to many are already working perfectly in Glide, and it is possible to show related collections of a record.

Congratulations for all the work. I’m sure that, specially for Glide Pages, which is more oriented to corporate users, the integration with Airtable will change the game.

@Mark I’ve edited this issue as soon I realized this doesn’t happen in all cases but frequently…


1 Like

This shouldn’t happen. If it’s not sensitive data, could you please invite me to your Airtable base?

This, Is it related?

thanks @Mark send me a message with your Airtable login mail and I will share this base with you. It’s a copy of the production table just to this test so I can give you edition permissions if needed.

Thank you! Your issue should be fixed by Wednesday.

@darder Your problem is that you’re over the row limit, so Glide doesn’t load all the data. You’ll see that you don’t have all your rows in “Acreedores”, but for the rows that you have the relation works. Lookups in Airtable will come over to Glide because they’re computed by Airtable, not by Glide.

1 Like

Yes, I was already assuming that this would be the reason.

I think that the limit of 100 rows in Pages, if Glide really wants to focus this tool on corporate users, is perhaps too low to evaluate its possibilities.

Thanks @Mark

1 Like

I am testing the Airtable with Glide Pages. Just wanted to get one clarification, in my Airtable, I have two relation column, one formula columm, one text column and rest are look up columns.

In Glide Tables, I am able to see all of these, but I am not able to use any of these columns in Editor (please see screenshot). I understand that I can not edit Airtable data, but atleast I assume I can use these data to show it in my app.

Is there something I am missing?

I don’t use airtable, so I can’t help too much, but I see a lot of array columns, which I’m guessing are your airtable lookup columns. Arrays can potentially contain multiple array values. Because of that you cannot use an array of values in a component that can only display a single piece of data.

1 Like