Accessing url of Web Element


I have an upload form in a Web Element where a user can upload multiple files because Glide does not allow uploading multiple files. When the ‘Thank you’ page is shown, I want to display a ‘Next’ button on the page.

I first tried using the Glide API in the backend, but it was prolonged 1 out of 10 times. The data is usually passed in 2 seconds, and the next button appears, which is excellent. But sometimes, it takes over a minute before the button becomes visible, which won’t work for our use case.

That’s why I would like to know if there is any way to access the current URL of the Web Element, so I can show the button when the URL in the Web Element has changed to a specific URL.

I tried using the JavaScript column, but it cannot get data from other elements.

I’m not aware of any way to do this, sorry.

Also not an object for example that is in the iframe?

No, not that I’m aware of. It is possible to access the URL of the current screen, but that won’t help in this case. I suspect that what you’re currently doing with the API might be the only way :man_shrugging:

Thanks! Do you know why the speed of the Glide API isn’t consistent? It usually works in an instant, but when it doesn’t it really takes over a minute for the value to update, which is really long

Might be you tier at Make. The higher tiers gets top priority.

No, it doesn’t have to do with Make, as the processing in Make was even shorter (1 second) for the scenario run that took a minute to appear in Glide, and it took 5 seconds for the scenario run that took 2 seconds in Make

1 Like

Just curious - have you observed these delays in the published App, or just in the builder?

In both the editor and the published app

Okay. I don’t really have an explanation as to why there can sometimes be delays. I’ve observed similar behaviour. Generally its almost instant, but every now and then one seems to get “stuck”. I have no idea why, sorry.


Thanks! Did you submit a support ticket already about this delay sometimes? If not, I’ll submit a support ticket, as this should not be normal behaviour.

I would give it a couple of days and see if it improves. I’m aware of some activity going on behind the scenes that might fix this issue.

1 Like