Webhook guidelines / limits

I’ve searched the documentation and of course read many topics here. Still cannot find an answer.
Is there a set list of guidelines for webhook parameters? Or its limits?
Here’s an example:
I’m sending a JSON parameter which includes many sub-parameters.
Among other, trying to send this parameter to a webhook: “22/06/2022 16:00”.
On Glide, the JSON looks perfect and this data is showing.
When sending in a webhook. this specific sub-parameters is showing as “”.
I tried triggering the same exact test from another webhook, in another app, and it worked perfectly.
Any thoughts?

My immediate thought is row owners.

If that’s not the issue, then it should be a matter of figuring out what’s different between your two test cases.

1 Like

Indeed. However, I cannot figure it out :slight_smile:

Sending out



Sending out




So you’ve ruled out row owners as the cause, yes?

Assuming yes, I’d have a close look at where that date value comes from, and the journey it takes to get to the web hook. Does it pass through any other columns - date formatting, math columns, etc?

Do you get the same results when triggered from the builder and the published app?

What happens if you replace the date with a simple text value? Does it come through?

What happens if you trigger the webhook action when viewing as different users in the builder? Do you get the same result with all?

Neither app has row owner

Sure. Many hoops :slight_smile:
But, the final result is shown in the screenshot I took of the JSON itself. Isn’t this what Glide sends out?

Both apps aren’t published

Goes through

Good question. Haven’t checked before. Have checked now and, sadly, same result.

Not necessarily. This is most likely where the problem is. Make sure you’re attached to the row you think you are when the webhook is triggered. Use the data view in the left hand panel of the builder layout to check the contents of the template column.

It’s a single row table (Custom form).

Same data as shown in the data editor

I have also tried to use SV column to grab the content of this problematic column. No luck.

What happens if you convert your date to a string using a template column, and then use that template column in place of the date column?

Very interesting idea.
Just tried it. No luck :frowning:

For kicks. tried to take it a step forward (towards even more weird): stringed the JSON column all together.
Still, no luck. JSON comes with an empty sub-parameters on the webhook side :crazy_face:

Okay, well I’m just about out of ideas.
It’s definitely something to do with the date, because…

If I had it in front of me, I might be able to figure it out. But I don’t, so I can’t.
Maybe somebody else will see or know something that I’ve missed, sorry.

Did you delete two posts, yours and mine, regarding CORS?
Or am I hallucinating ?

I can’t speak for your state of mind, but no, I haven’t deleted anything.

Your webhook titles need to be the same each time. In Case 1 the title was TestFromMake and in Case 2 the title was JSON4WebHook. I ran into this issue the other day. Maybe try running two cases where the title is the same and see if your are getting the same error.

Thanks to @SantiagoPerez from Glide support team, this mystery has been solved. Well, mystery to me at least.
So, it appears that when using an experimental column, its value has to be physically visible on the app screen in order for it to be sent out in a webhook payload.
Now, this is a problem. These column are sometimes (most of the time?) completely irrelevant to the app users. I know for a fact that some of my users will be utterly confused when showing them data they don’t understand.
I have tried to play around with visibility conditions. Sadly, each time this value is not physically visible on the screen, it won’t show up on the webhook.
Has anyone figured out a way around this?

Ah, I remember that case, it should be our option #5 to be checked by you and help you better. :woozy_face:

If I’m not wrong, the workaround is put your data in some components (Text or Table) and play with their visibility in order to hide them or some CSS trick to change their font color.

Try this trick and let us know the results please.


Happy to hear ideas.
CSS seems like a crazy complex trick to support on multiple forms/values/etc.

I’m as far as you get from understanding how Glide works behind the scenes, but it’s very surprising that Glide can “see” the values on the columns themselves (visible or not), but cannot send them via webhook unless they are physically visible. Does this mean Glide is scraping information from itself?

This bug should be almost 2 years old and I don´t know the cause yet :upside_down_face:

Hi all,
On the same topic:
I have noticed that the webhook is firing by itself, without any user involvement (or even when the app is 100% untouched by anyone). It seems to be connected to these notorious experimental columns (not sure). I haven’t seen this sporadic behavior on other forms, but I haven’t really looked into it before just now.

I know how amazingly frustrating this has been to me, so I thought I’ll post it here to save the hairs from falling on anyone else’s head.
See below from Glide support:

Thanks @SantiagoPerez .

1 Like