Unexpected system language. Possible fixes

Can anyone tell me how to change the language of the App I’m creating now.
Everything showing Japanese Language, Cancel button , Send button showing Japanese
Language form…

How to set it back to be English Language…

It’s likely because your device’s primary language is Japanese. Can you try changing that to English?

In my windows I can switch to 3 languages when I type something

  1. English 2. Thai 3. Japanese

My widows works normally in English language as same as in Google.

I saw this apprence showing when I’m
creating my app.

I want to know, how to set my app to show in English language… not Japanese language…

ในวันที่ ส. 17 ก.ค. 2021 18:32 น. Thịnh Đinh via Glide Community <glideapps@discoursemail.com> เขียนว่า:

I mean this.


For your app, the display will depend on the user’s device, not yours.

Now, I finished creating my App, but
why the App language is still showing in
Japanese language as you said

“The display will depend on user’s service”

My divices has no Japanese Language at all… But the App I created is now showing in Japanse Language

It is for Japanese people or those who can read Japanese language.

So, at this point really, I want to ask,


ในวันที่ ส. 17 ก.ค. 2021 19:17 น. Thịnh Đinh via Glide Community <glideapps@discoursemail.com> เขียนว่า:

Can you send us the link to test what language it displays?

Just to be clear, only some Glide “terms” will change the language depending on the user’s device settings. The content created by you will show exactly like what you entered.

Can I have your e-mail, I like to send all progress for what I did, in pictures,

You can figure out what is happening…
with my app for Japanese Language mode came out of now where !!!

ในวันที่ อา. 18 ก.ค. 2021 17:31 น. Thịnh Đinh via Glide Community <glideapps@discoursemail.com> เขียนว่า:

You can send them to ariesarsenal@gmail.com or via private message on here.

I send the file on this given mail.
Pls, find my excel attachment in the mail, so you can see the problem…

1 Like

Why can not you tell me what to do,
or showing step by step to solve this language problem. ???

You can capture the step and show in excel file
then send to me is so much appreciated…

Unless @ThinhDinh finds something different…In addition to checking your computer’s language setting, I would also check you browser’s language setting to make sure it is set to english.


Sorry, it was Sunday night so I was not online to reply instantly.

As Jeff said, we have shown all the possible ways the settings can affect your app language. I don’t have a Windows computer here to show screenshots, unfortunately.

Windows-level language settings walkthrough:


Browser-level language settings (Chrome):


Google account language settings:


If you have gone through all this and still can’t find the answer, then I would advise you to publish that app and send us the link to test it. As we have default language settings likely to be different from you, we can see if it makes a difference.



I’m thinking my Google Account has something wrong with language displaying …

The mail , and everything works fine with English , but when it has Pop-up messages
it shown in Japanese ???

** I have below excel file attachment this mail, Could you pls find out what’s gone wrong about The Japanese Language Massages …

As you can see, the language I set in my Google Account is English…
But the Japanese Language still displaying on the screen as usual …

(Attachment Language Displaying.xlsx is missing)

I send an excel file , showing my Google Account in Language setting mode…
(But it had already set as English…)

(It seems my attachment doesn’t reach to you all, I means the excel file attachment could not be sent out together with my mail, It allowed sending out only the messages.)

For testing purposes, as @ThinhDinh and @Jeff_Hager suggested, you might want to remove anything related to Japanese in your computer and phone settings: input language, keyboard, display language, Google account, browser.


  1. Is it possible that you have software installed that is overriding the settings of your Windows/Android OS, for instance a launcher or remote settings from IT if you are using a computer from work?
  2. Did you create your app from scratch or from a template?

I don’t think it is necessary to remove things related to Japanese in my Notebook now.
That’s because I have another Notebook which has not thing related to Japanese from the
beginning. (It has only English and Thai)

On the other hand , I did change Google Language display to English , and try to sign-in
glide app again, but the results showing to me still remains unchanged
( The App I’m creating still showing all the information in Japanese, holy… )

Yes, I build my App from the scratch, no using any template.

It’s kind a hard to explain in here only wording (If possible , I’d like to capture what is happening by picture, so, we might get to the points, and really find the way out of the problems together here)

Try doing a video screen capture with Loom and share here?

I made it !!! Change language displaying , You have to set it in Chrome !!

It is not in “manage your google account”

Holy … this is quite a simply but no one can answer me…

Such a waste of time… I knew it already, and I made it now…

Once, the language has changed correctly the app you are creating will change language in itself in displaying language the way you want it to be.

2 days for this problems.

Congratulations and thank you so much for sharing your experience, it surely will help someone in the future.