Switch's effect can't be undone?

I added a switch component to try out. It wasn’t what I needed so I deleted it, but the changes won’t go away.

Basically, I have a collection grouped by “type”. Now, the item affected by switch is in it’s own group and the text is wrapped strangely?

I tried undoing, resetting the data value, readding the switch to turn off. Nothing. Can anyone help?

I’m not quite following, would you mind adding a couple of screen shots?

  • Show the column in the Data Editor that the switch was writing to
  • Show what the collection looks like in the layout
  • Show how the collection is configured

As you can see the top item is separated despite having the same “Type”, and the name wraps by the letter instead of by the word like the others.

That’s interesting. Are you sure there isn’t an extra space in the Type somewhere in row 1?
What happens if you copy the value from row 2 and paste it into row 1?

Where and how were you using the switch?

I tried that and nothing changed. But I just tried the opposite (copy row 1 to row 2) and that worked somehow? Did the same for the rest so grouping is fine now, but the text wrap is still off on that one item.

Not sure it will solve but what if you change the column type to something like number… save it… then back to text again.

Okay, I think you might have been bitten by a known issue with copy/paste. The issue is that sometimes when you copy and paste a value that includes a space, Glide inserts additional non-visible unicode characters. Which can break things like relations, filters and grouping.

Try typing the values out instead of pasting them.

For a more robust option, I’d recommend creating a separate “Types” table, add a RowID to that table, and insert the RowIDs instead of the Type names into the above table.