My components are not picking up the data of the relation columns

I want to show the data of the relation column made in a particular table into the front-end but none of the component is picking up the data. Can anyone help me regarding this? The relation includes multiple data in a single cell and I want to show that data as chips which are not clickable.
I can’t come up with anything. Does anyone know how to do this?

Try using a collection.

1 Like

Yes, I tried but still no option of selecting the data from the relation column

Did you set the relation as the source of the collection?
Can you share a screenshot please?

Yes, Here.

This is the Relation Column:

Screenshot (164)

This is the what is showing to me when I want to add the data of the relation column in the “Description” input box of the “Column” component.

This is the whole “Treats” folder tables:

There is no such thing as a “Column” component, so I’m not exactly sure what you are referring to here, and your screenshot doesn’t show enough to be able to tell. But I’m guessing it’s a component that expects a single value.

As I mentioned in my reply to one of your earlier questions, a relation doesn’t contain any actual data. It’s just a link from one row to one or more other rows. If you want to use values from the other end of the relation, then you need to fetch those values. With a single relation, you use a lookup. With a multiple relation or a query, you use either a single value column or a joined list - depending on what you need.

I’m not exactly sure what your end goal is here, but hopefully the above gives enough information to get you on the right track.

1 Like

I’m sorry I mistakenly used “Column” Component. It’s “Collection” Component. And Let me share you the full Screenshots:

As you can see in the relation column there are 2 diff values and I want them to displayed in different chips or cards. And I tried implementing the joined list as recommended by you but it’s giving the below result:

In the below screen shot, I can’t actually see if you have selected the relation as the source of the collection:

It looks like you haven’t, because only one card is shown on the screen. And that suggests that you are using the current row as the source of the collection.

Please double-check that. If you aren’t sure, show me a screen shot of that same area without the menu obscuring the rest of the settings.

Okay, Actually that’s the previous screenshot. These are with the Joined List implemented:

I still can’t see what the source of your Collection is.

Okay, so there is the problem:

You have the source set as “This item”, which is the row that the screen is attached to.
You need to change that so that your relation is the source.

But I can’t do that because doing this will break the link from which this information is getting opened. Upon selecting something this further information fetches up.

Sorry, I don’t understand that.

Selecting a relation as the source of a collection shouldn’t break anything.

Can you show me what you mean please?

It would be difficult to show or explain for me. I’ve applied a lot of things in it actually. But thanks a lot I’ll figure out something.

Can you just show me what it looks like when you select the relation as the source?

1 Like

Going back to the post, I think the core issue is this.

Think of relations as the pathway connecting two tables. The “values” you see in the data view is just a way from Glide to show you that there’s a row that is returned based on your configurations, not actual data that you can show in a component.

You would want to use a joined list over that relation, get the text as a delimited list, and then display that in your collection, if I understand that right.

Or explore custom collections, HTML and display those in a rich text component to preserve the pills look.


Oo it worked. I’m sorry to respond this late, I slept last night so I couldn’t respond. But yeah changing the source worked. I was thinking something else would happen if I change the source but surprisingly it didn’t. Thanks a lot.
I was thinking that if I change the source it will pick the whole data rather than data to the corresponding person bio I opened. That was in my mind actually.


Thanks a lot for your help as well