IOS issue with Deselecting or clearing Date/Time Entries

My app’s URL:

We are using the Date/Time component for learners to indicate an activity has been completed. However, considering there might be instances where folks accidentally select this or realize they aren’t complete, we are realizing there isn’t a way to “Clear” the date/time field. When selected there is a “Clear” option on date/time selection wheels; however, nothing happens when you select clear. In some instances, we have noticed it does not clear, but ultimately reverts to an 1899 date :slight_smile:

Any insights would be greatly appreciated.

(Image attached)

1 Like

I see that too. Probably because glide is seeing the column as a date column. What happens if you create a new column within the glide editor, but make sure it’s a text column instead of a date column. Then try setting the date to that new column?

1 Like

Hey Jeff. I just tried this but unfortunately didn’t work for me. Same outcome as before.

Hope the Glide team can develop a calendar functionality soon! Would be really cool if you could select recurring time slots (every Tuesday at 8pm).

1 Like

I’ve tried this…and text columns can’t be filtered by “on/before/after/within today” nor can they be formatted short/medium/long

1 Like

Manually add a date to the first data row in your sheet, then refresh the data in the data editor and set the format of the column to date. Then you should be able to “clear” the date values entered by your users. No?

I would like to use the date or date/time picker but this combined issue is preventing me from using it, which is a shame.

Just wondering if this is being looked at?

I have tried everything but unable to clear date using date component on iOS.

Is it a glide or iOS issue?


1 Like