In this case here the function “If-Then-Else” with “IS EMPTY” "is not doing the exact opposite of what it should be?
Is that a bug?

the problem appears in the next column, returning the values exactly where “IS NOT EMPTY” …

but I see the logic right and the result too.

Only 2 rows aren’t empty therefore, I can see 2 zeros (0) in your screenshot.

Saludos @Rodrigo_Serpa

1 Like

Thanks @gvalero, but I just put the other image of the problem, where it returns the opposite, where de rows IS NOT EMPYT…Do you know what could be wrong?

Aja… I think I have seen what you mean. Let me check one of my APPs to show you the same problem and its workaround.

I will be back!


This was what I saw days ago with something similar to your case.
At the beginning, my original logic was this:

but it never worked fine and I supposed it was a bug.

Later, I exchanged the logic and parameters like this:


… and everything works perfectly!. There is something wrong with IF-Then-Else component when the first THEN field is empty by default.

I think @Mark can see it and fix the bug quickly.

Feliz día!

@gvalero Sorry, I cannot reproduce this. Could you please share the app you’re seeing this on, and tell me exactly how to reproduce it?

Sure @Mark

As soon as I come back to my house I will make a simple APP to help you.

The issue is when the first THEN field is blank using Is Empty as conditional.

Nos vemos

I tried that, and it worked as expected:

Hi Mark, in my app column I have 2 cases (like a “IF(AND(…”) and only when I put these 2 cases together the problem appears (exactly like the second image I put)

I can’t see what’s going on in your second screenshot because all the columns you’re using are obscured. You can move columns by dragging them on the header.

Sure, now is clear.
The condition is set "IS EMPTY"but the return are in rows IS NOT EMPTY

Sorry, I don’t understand.

Your If-Then-Else column says

If SELECT_COD is empty, produce an empty value
Otherwise, if ANO is 2019, produce RENT_ACM
Otherwise, produce an empty value

That seems to be exactly what it’s doing.

Hi again

Reviewing my APP now I can see my problem disappeared, everything is ok now but this issue was there 1-2 weeks ago. I was using 8 columns with that logic and none worked so I had to use an reverse logic as workaround and everything worked w/o problems.

Well, close this case!

Gracias @Mark

Hi Mark,
As @gvalero wrote my app started to work well too. Even with DATA ok, the app for some reason used to do the opposite logic, but now it’s solved.