How to: Troubleshoot inconsistent container sizing esp. in mobile view? (w/ video link)


I’m trying to figure out why the width of my containers is inconsistent.

The settings and file for the background are the same. The smaller width is the one that I want but I must be missing something.

Even in the non-mobile view it’s not the same width for each.


Do the button blocks contain the same set of actions?

Yes. They all just change a word in a column which is used to unhide a container.

Have you tried copying a “working” container to another tab to see if it works?

I also copied it to a new screen.

The smaller width version becomes bigger even when copied to a new screen.

They all execute properly which is a plus.

After some observation I’m wondering if the width of the uploaded file itself is a factor?

But aren’t they all the same file?

I did notice that if I switch the container background to dark or accent, they by default have the same width and height as the background photo.

Is there a way to change the background while the setting is Card?

Exactly! Therein lies my :thinking:! :joy:

@ThinhDinh Found a work around. Thanks for your replies because troubleshooting helped get me there.

By adding a separator outside the container, that made the height smaller. My apologies, if I originally posted width when I meant height.

Thanks again for the guidance!


For what it’s worth, as you’ve noticed @JamieErvin, the height of components seems to be too big at times. This has to do with lower margins I think when there isn’t another component below. Also, some components such as the title or collection component “merge” with the header of the screen to create a very large colored background on certain appearance settings (when the style is set to accent).

I often add the separator component (small, line hidden) at the very top and very bottom of my screens to see how that might change things.

1 Like

Thanks for the reply!

This was my first time encountering this issue. I’m relieved to read your suggestion as well. Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.