Glide table not updating

Here I have a problem with Glide tables not updating on changes in Google sheet - even after several times triggering the update button in Glide builder?
Has anyone seen this recently?

Are you having trouble with a glide table or a google sheet? They are separate things. I’m assuming you are referring to google sheets. So you are making a change to the sheet and it’s not syncing to glide? Have you exceeded any row or sheet edit limits?


Correct, changes in Google sheets don’t show up in Glide table. It’s a pro app and no limits are even close.
I have seen this recently not only with normal columns but also with rollup columns based on relations which didn’t sum up correctly

To be clear, Glide Tables do not have any connection to google sheets. They are a completely separate database stored only within glide, whereas Google sheets can be viewed and used in glide…and are basically synced version of glide tables. But they are different and can be differentiated by the green icon for google sheets and the black icon for glide tables.

So, it sounds like you have tried the sheet data refresh/resync button? There were no errors? If you change data from within glide, does it sync back to the sheet? Have you refreshed the browser? Do you have a video of this happening?


@Jeff_Hager , sorry for confusing the terms Glide table, I mean the tables in Glide (green icons) which are connected to Google sheet tables, don’t know what correct name they have.

Yes, I tried the refresh button several times without errors, and it didn’t help. If I change data in glide it immediately shows up in Google sheet. I also did restart my browser etc…

Unfortunately it is not easy to reproduce, sometimes it is working sometimes not, but it comes again…

In the situation when the syncing problem occurs I’ve noticed another problem, maybe they are linked:
In the builder, if I change a user specific column in a screen via a button, the changed value does not show up in the data editor section in the left lower corner. Here one would expect immediate update as no Google sync is involved. Sometimes it helps to refresh the user specific value in the data editor by double clicking the field, sometimes not …
Sending a video as PN

Sorry, I shouldn’t be such a stickler for details. I sometimes intermix the terms Table and Sheet too, but I just wanted to make sure you weren’t expecting a google sheet to affect a glide table. I looked at your video a couple of times.

I can see the same thing when I try to increment a user specific column. It doesn’t show the updated value in the data panel at the lower left, but I do see the updated value in the main Glide Data Editor. As for the ItemsInCartSum column, that does seem odd. I can’t see anything that you would be doing wrong. Can you confirm that the value is also still a 1 in the data editor as well? One thing you could try is to first duplicate the app with the same sheet to see if you experience the same problem with the duplicated copy. If it still doesn’t work, I would also try duplicating the app with a new sheet to see if that works the same. I’m thinking that a duplicate may force the new app to reconnect to the sheet properly and resync. Do you experience any problems with the published version of the app, or is it only in the builder?

Otherwise you may have to open a support ticket with glide.

1 Like

Thank you for your time looking into this!
Yes, the user specific value does update in the main Glide Data Editor :slight_smile:
And yes, the value of ItemsInCartSum in the Data Editor is still 1 (not synced).

About duplicating the app: I do this from time to time for backup reasons, but then the new version is my backup and the old stays as production version, as this is a PRO app and linked to a custom domain.

If I would continue with the copied version, how would I transfer the PRO to this app and I would expect problems with switching the domain? Have you done this successfully?

1 Like

Yes you would have to transfer your pro subscription and domain. I haven’t had to do this before so I probably can’t give you good or reliable advice there. I’d maybe start with the duplicates or create a new column and switch everything over to that new column. If there are still problems, I’d try support before resorting to transferring everything to a duplicate.