Glide is not always working good

It should resolved itself, but admittedly I have never come across your bug before.

If the faulty app doesn’t disappear:

  • Create that new team
  • Create the new app
  • Transfer the apps you need to keep to the new team (Right-click on the card menu of each app > Transfer)
  • Delete the team with the faulty app

Today I just logged in, and everything looked okay.
Even the " faulty" created app looks normal on the project’s screen.
With creating my " new" app, I think I also need to redesign things.
With the new app, things have changed a lot and I really need to have a good look around to find things and maybe rethink my layout.
This is what I get when I did not check out Glide for almost 8-9 months :slight_smile:

I think this was not the first time that this strange thing had happened to me.
Anyway, I know what to do next time. :slight_smile:


The current situation is as follows.
I left the colors for what it is.
Maybe it is just something I will get used to, and I am the only one who is using the app anyway. :slight_smile:
The reason why I re-created to the app in the “New” Glide, is that I was hoping that the issue I had in the “Classic” it would solve the same problem that I had that the stock would not update always. And in the “Classic,” you did not have the “Wait” feature.
The “New” app is working, but now and then I can see that the stock is not always updated immediately. I had put a 3-second wait in the custom action and thought that this had fixed the problem.
But I can still see it.
But when I checked the details, the correct stock is shown there.
And when I go “back” out of the details, the correct stock is shown.
Now I noticed, that when I take 3 tablets, then switch to a different screen and go back to my “Home” screen, the stock is also shown correctly.
It looks like, that is there is a refresh or rebuild of the screen, the stock is shown correctly.
I had tried to look in the custom actions if there is something like a refresh screen, but I did not see it.
Does anyone have any idea on how I can do a refresh of a screen?
I hope my explanation makes some kind of sense.

Is there maybe a bug in GLide or is there something else going on?
In my last reply I mentioned that even after re-creating my app in the “New” Glide, it was still not working the way it should.
That maybe there is some kind of refresh needed to get the correct information on the screen.
As I expected, there is no refresh option in the custom actions.
What I first tried was the “Go Back” feature.
This had no effect.
Then I thought, maybe stupid but I will give it a go anyway, I used the “Go To Screen” feature and I let it go back to the screen I wanted.
This had some effect.
The first few days I tried this, it was updating the screen with the correct information.
But after a few days, it was showing the incorrect information again.
I waited several seconds but nothing happened.
I even switched to a different tab and went back, but still, the wrong information was there.
I also tried closing the app fully and restarting it, sometimes the info was correct, and other times it was still wrong.
I also tried to look at the details of one input, to see how the stock was shown there.
There it showed the correct stock, but in the tab, the info was wrong.
Today I tried to make a screen shot and I wanted to show it here.
As soon as I had made the screenshot, the info on the screen was shown correctly.
In this screenshot, the stock should be shown as 94. Because I had just tapped the button to take 3 capsules.
But as you see, it is still showing 97

After taking the screenshot, the stock suddenly was changed to 94. This is what it should be.
My thoughts were to show you the details of the last “Take 3 capsules”
Because in there it is always showing the correct stock.

I have no idea what is going on here.
The first few days, it went okay.
Then I placed the “Go To Screen” feature, and again, for a few days, it was okay.

The custom action is as followed;
Add a new row, with updated info.
Show notification
Wait 3 seconds
Play sound
Delete row (This will delete the first row in the table)
Go To Tab Kalium-Citraat

When the new row is added, the correct info is stored in the table, so the stock should show the correct number. But it isn’t

Can the cause maybe be that the other tabs are connected to a Google Sheet? And that this slow down or cause any problem with the Glide table?
But for the Kalium-Citraat, the Google Sheet is not used. Only the Glide Table.

Maybe anyone has any idea what is going on here.
Right now I am thinking of re-creating the app again, and maybe creating a separate table in which I place the stock only.

This morning it was acting up.
But this afternoon, the right stock was shown within 3-5 seconds.

I created a separate Stock Table. In there, I have my Stock and a math column that calculates how many days are left for the stock to finish.
Maybe a stupid or dumb question, but how can I, in my custom action, open that separate Stock table and deduct 3?
I only see the option for This Item, User, and a roll-up I have to a different table.
Also when I choose, Set Values, I only see the same tables.
(This is the problem if you don’t work with something for almost a year. You forget things :slight_smile: )

You need a single relation to you stock table. Then you can use a set column action to update values through the single relation.

1 Like

Sorry, I am drawing a blank here at the moment.
I think that in both tables I need to have something that they have in common, but there isn’t
I am getting a ? or something like -3

At the moment I cannot think straight anymore, I am hitting a wall.
I know I am doing something wrong but I cannot figure it out. :frowning:

To create a relation, yes there needs to be a common value between both tables to create the link.

If you already have a relation and it at least showing something (even a ?) then you know your relation found a matching row. If it didn’t show anything, then the relation did not find a match.


I think i will give it a go again tomorrow.
Unless someone can explain why things are not working correctly without me creating a seperate Stock table. This was my idea of trying something different, in the hope things would work the way it should.

1 Like

I often encounter similar situations in my apps where something doesn’t seem to work, I feel my “smart” setup should work, and I have no clue how to proceed to fix my issue.

I’ve usually noticed the following:

  • The problem is usually not a bug, it’s my own doing. It usually stems from my limited understanding of Glide. Once the issue is solved, I learn something new on the way. This happens to me all the time.
  • I’ve made things too complex, unknowingly.

Here’s what I would consider to troubleshoot your issue:

  • Using Glide Table exclusively instead of Google Sheets. Less syncing involved.
  • Breaking up custom actions. I don’t know exactly what you set up, but how about separating create, update and delete actions into separate actions.

How do we know if we’re using Classic app or New app?

In the Dashboard, the image for a Classic Apps and a newer Apps are slightly different. One says ‘classic’, the other one doesn’t. Unless you have a very good reason to create a new classic app, I would always avoid this.