Glide is not always working good

Hi Glide community members,
I hope that maybe someone can help me or give an explanation of what is going on.
I will try to explain things.
I have a free plan and created a simple app to keep track of one of my medications.

Three times a day, I take this medication. Each time I take three tablets.
That is why there is one button that says “Take 3 Capsules”.
If I get my new tablets, I always get 270 pieces. That is why the other button says “Add 270 pieces”
Each time I take three tablets, it will add it to the list below. So I can see if I already took it or not.
In the last few weeks, I noticed, that the taking of three tablets is not always working.
When the app opens, I press the button to take 3 tablets, but nothing happens.
Normally, the “On Stock” should get three less. But it stays the same. Nothing is deducted.
But it is appearing in the list below.
Sometimes I need to wait a few seconds before something happens.
Other times I waited for more than 10 seconds, but nothing.
Other times when I press the button to take 3 tablets, immediately things are okay and correct.
Before I was using Google Sheets to keep track of it. But when I noticed that these things started to happen, I created a Glide tablet, hoping that this would solve the problem.
But not.
I also made things in such a way, that every time a new row is added, the first row will be removed. This way the list would not get any longer than three weeks.
(That is happening because of the last column)
(Here is the Glide table)

When things are not working correctly, I press the first item in the list to get some details.
These look okay.
When I do an “Edit” on those details, I also can change the total stock number.
When I save it and go back to my “home” screen, the total is correct.
Also when I do the “Edit” in the details screen, the stock total is already showing as correct.
But on my “home” screen it is still showing it incorrectly.
I am still using a Google Sheet for the other options in the app, but not for this medication.
Also, I have tried to open the app, wait a few seconds, and then tap the button to take 3, and sometimes this is okay. Other times, the same problem comes back again.

I hope that my explanation and what is going on is a bit clear, and I hope someone can tell me what is going on.
Right now, it is not really reliable. Sometimes I am a bit in a hurry and don’t pay attention to see if the stock is changed or not. Only to find out later that the stock number is not correct.

Many thanks in advance for all your time and help. :slight_smile:

So “Take 3 Capsules” and “Add 270 Capsules” both add a row in your Logs table? Do you have any other actions tied to it?

How do you calculate your On Stock number?

And what table is the Kallum Citraat screen built on?

Both buttons will add a row.
Here are some screenshots to, hopefully, explain how things work.
The table used for the Kalium Citraat is a Glide table.

This is how NextStockTaken is calculated

These are some screenshots of the On Stock calculation


As I maybe already mentioned, “most” of the time it goes okay.
But now and then, it doesn’t work.
The KaliumCitraat first was in the Google Sheet, but when I noticed this problem, I thought that maybe it was because of the Google Sheet and that there maybe sometimes is a bad connection.
That’s why I created the KaliumN Glide table, in the hope that this would fix the problem.
But it is still happening. Now and then.

Hi, Pierre_de_Man!
First i suggest don’t trying to get last from KaliumN (especially if it in Google)
First convert date to number then find the row with largest number and relate to this row to get Latest stock.

1 Like

KaliumN is a Glide table and not a Google Sheet.
The Glide table will not get any longer than 67 rows.
This is why I still choose to get the last row.
I can imagine that when you do this to a Google Sheet, it will take some time.
As I also mentioned, sometimes it goes wrong. Other times it is right.
Right now I can not figure out, when it goes wrong and when it goes right.
My thoughts are, that it should go fast enough and that it should be consistent.
But for some reason, it’s not.

Thats why i suggest to deal with time based last instead get last row.
Think, you doing delete row and add row at same action. My opinion is to give some time to establish all syncs’ accordingly. Wait condition (combined with relation to date based “last”) guarantees you operate proper data.
P.s. We don’t know how Get last works. Thats why no answer where the problem. But relate to biggest numeric date is clear.

And another idea is to change the order from delete row, add row to add row fist and to delete row second

1 Like

I will try to switch the delete and add row, first to see how that goes.
If it still goes wrong, I always can try your first suggestion.
I also tried to see if there was any delay in the custom actions, but there wasn’t. :slight_smile:

I had tried switching the ADD ROW and DELETE ROW but the issue was still there.
Maybe it sounds and looks a bit strange or stupid, but I did this because of a remark that was made.
Something about delaying things or that we don’t know how things work in which order.
So, just to try something, in the custom action, I place two more notifications.
For now, I have tested it for 1 day, and so far things look like it is working.
Only when I will test it longer, I will be able to say if this really worked or not.

There is one strange thing.
The three notifications are right after each other.
Because things sometimes go so quickly, I gave them all three a different notification.
Something like 1, 2, and Succes.
But the only notification I see is the SUCCES.
Maybe someone can explain this?
I checked when it was updated, and it was showing, just now.
I also made a change somewhere in the text, and that was visible immediately.
So the app is updated.
If no one has any idea, then never mind. I will just see how things will work in the long run.

I do suspect that the speed of the actions running is a factor somehow. Glide has never really clarified how custom actions are executed. Whether is synchronously where each action depends on the previous action completing first, or asynchronously where all actions are ran at the same time. Without fully knowing how it works under the hood, it’s become a bit of a mystery box where some things work and some things don’t, and sometimes the results are random as you’ve noticed.

This randomness led to a big push by users to have some kind of Wait action which Glide finally gave in and provided for us.

I don’t know if it would be beneficial to have the Add Row or the Delete Row first. Theoretically it should not matter, but I think I would definitely use a Wait action between the two instead of trying to string multiple Notification actions together as a way to slow things down. Notification actions are very simplistic, so they obviously run very quickly and I assume the last notification is the one you will ultimately see. On the other had, the Wait Action definitely introduces a known delay between actions. The basic Wait action is just a simple delay before any subsequent actions are executed. Still not sure if everything runs synchronously or asynchronously, but the delay does help. There is also a ‘Wait for Condition’ action which waits for a certain condition to be met before continuing. I don’t think you need that action, so the normal Wait action should be sufficient.


Can you maybe tell me where i could find the eait action in the custom action?
I already tried to look for it but eas not able to find it.
Unless it only eill show in a paid plan, then i will not see it. I am dtill using the free plan.

I guess we should probably clarify first. Is this a Classic App or a New App? If it’s a new app, it’s simply an action called ‘Wait’


1 Like

ts a Classic app. I already made it last year.
I did a search, but the wait is not there.
Anyway, it looks like the three notifications, for now, is doing the same thing :wink:
So I will try this first for a few days, just to see if it keeps on working right.

By the way, is there a way to convert a classic app to the new app?
If not, thats okay.

1 Like

No, there is no easy way to convert to a new app. You can create a new app from data, which will retain your computed columns, but you would still have to to rebuild the front end. Slowly going through that process myself right now.


What does everyone think is better?
Continue developing/improving the “Classic” app, or try to re-create it in the “new” app?

Better or not is up to one’s opinion, but Classic Apps are deprecated and will eventually go away. I don’t know when that will happen and hopefully Glide will have a conversion tool by then, but I wouldn’t hold my breath that it would be a perfect conversion. You would most likely have to still do a lot of cleanup after that fact.

Classic Apps do not receive any support from Glide and they do not receive any new features or updates. So in my opinion, it’s best to focus on new Apps if you can. There are still a lot of classic apps out there (including mine) and there are some features that only exist in classic apps, but I’d rather spend my time working with a supported product as opposed to working on a product that has an end of life. And I especially prefer to do it on my own schedule instead of pushing it off and being forced to rebuild something on a tight schedule. It’s a great way to sit down, reimagine your app, and maybe improve on it without interfering with the original classic app.

New Apps have several new features that are not available in classic apps, and that feature set keeps growing. They are responsive web apps that automatically adjust to different screen sizes, so it looks good on mobile devices as well as desktop devices.

There are a handful of things that I don’t like about New Apps at the moment, but I’m hopeful that they will improve in due time. For now I just need to think outside the box when designing some screens, but for most people, I think the experience is much better than classic apps. Overall though, I think it’s definitely an improvement over Classic Apps.


Okay, today I thought I would recreate my old app in the NEW app.
I created a new app using a Google Sheet.
To be clear, I made a copy of the Google Sheet which is used for the Classic app. I also gave it a new name.
And I cleaned it up a bit and removed the columns I am not using anymore.
Later I want to create a Glide table also.
When I am on my projects screen, it shows the new app with no icon and the text Classic.
I also see the text Loading.
I already refreshed the screen, logged out, and logged in, but no change.
I don’t think this is normal.
I waited several minutes, but there was no change.
I tried to delete it, but I can’t
Is there something going on with Glide or did I do something wrong?

I agree, this isn’t normal.

Just to be safe, try the following:

  • Create an entirely new Team: In your Glide Dashboard (the screen with all of your projects), bottom left, there is an option to create a new team.
  • In the new team, create a new app (not a classic app) and create it from a Glide Table directly.
  • You will be able to add your new Google Sheet spreadsheet inside the app.

There is a better way to get started from a classic app. In your dashboard click the three dots in the top right of your classic app and select → New App from data.
Image 10-27-23 at 12.12 PM

It sounds like you may have “Created a Classic App” instead of creating a “New App”… that little detail is important. Only older users of Glide have the ability to “Create a Classic App”

You could try again by clicking Continue on the create a new app screen and then connecting your Google Sheet manually.

As far as I know, I selected to create a NEW app and did I not choose to create a Classic app.
I will try your option, else I will create a new team and try it again
I just hope that later I can remove the faulty app.