"Could not save your app. There was an error saving your app"

This has been appearing for a while and I have so far been able to get around it by deleting sections of information that were not vital to the app, which seemed to free up the ability to save the new sections I was making.

The notification then reappears after a while and again you can delete more of the less important information. This is not very satisfactory as you have to throw away sections to make new ones.

Could this be because I’ve reached a content limit and need to upgrade? Surely if that were the case there would be a specific notification of it?

This message seems to have been reported several times in the past and been resolved by the Glide Team?

I’d be extremely grateful for any advice!

In the Glide dashboard, could you navigate to the the team and check:

  • what plan you are on: you will see the plan just below the name of the team
  • what the usage is: you will see this by navigating to the Usage section, lower left between Members and Billing.
1 Like

Hello Nathanael, thanks very much for engaging with the query.

My plan is Legacy Starter

Usage data as follows;

0/15 Private Users
3/1000 Public Users

For my main app = 1870 rows
Small trial app = 15 rows

37/2500 on the main app

Hope this is helpful!

You seem to be under all of the limits on the Legacy Starter plan.

Are you uploading a lot of images or files?
Or does anything else stand out in the usage section in the dashboard?

Thanks Nathanael,

It didn’t look like I was approaching any limits… this project is a demonstrator prototype and has a very limited audience and I’m the only one adding any design or data.

I may have a lot of images (I don’t know what a lot is!). I estimate that there are about 650 images. I haven’t been very disciplined about their file sizes, so there could be a lot of data involved?

There’s no other information on the usage page.

Still in the dashboard of the team, you can head over to the billing section and then scroll down to team quotas on the right side of the screen? There you should see something about storage.

Do you get the same behaviour if you use the Glide Builder in a different browser?


I’ve just found that and it seems fine:

285.2MB / 6GB

Thanks Darren,

I’ve been using it in Chrome all along but tried Safari earlier today and it did the same thing…

You could try signing out of Glide and signing back in in incognito mode to see if that helps.

Thanks, I’ll try that now.

Thanks Nathanael,

It worked for a couple of changes but has now appeared again…

How is your Internet connection: strong, stable, behind a VPN?

You could try changing connections, for instance from wifi to data, to see if that has any bearing.

You’re right! Connection speed is fluctuating quite a lot and getting this notification occasionally.

The first problem has settled down and it seems it may just be the connection speed now.

I’ll work on the wifi and hopefully everything will be good again.

I’m extremely grateful for your help Nathanael. Big thank you.

If the problem comes back may I return to you?


Of course. Just like everyone else here in the forum, I won’t be able to do much about it but to try to troubleshoot with you.

I travel a lot by train and encounter the similar issue. It’s almost always related the my internet connection.


Thanks again. I’m extremely reassured!

All the best, Jonathan

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.