Choice component - fixed options


I am slightly worried I am missing something obvious, but I have had a good look around and can’t find an answer. Apologies if I am asking a daft question!

I am using a “Choice” component to select New, Resolved, In hand etc - and it all works well.

BUT! The choice component makes its options available by reading through existing entries. So that’s fine, until all “In Hand” entries (for example) get resolved - then all of a sudden there is no option for In Hand.

I’ve looked to see if there is a way of fixing the options available - but can’t find it. Also tried adding a table (using Glide tables) for Status then a relation - but I can’t get the Choice component to read from any table other than the one selected for the current screen.

Hope this makes sense - any advice much appreciated.


This should work, but you don’t need the relation. You should be able to select any table to be the source of your choice component.

1 Like

Thanks @Darren_Murphy - Much appreciated (again!)

Worked it out a few moments after posting - typical

In case it helps anyone else - I foolishly had my source selected in correctly.

I at first did set it up with a relation and set the “Write to” field as the relation field. Doing so - removes the “Source” option. If I select the “Status” field in the main table (with all the logged entries) - I can the select a different table (in my case - source)

Two screenshots attached which may help explain in case any one else is blind like me!

Thanks again,

1 Like

Yeah, that’s a bit of a trap. We never used to have that option to write to single relations, but that was something that was added a while back to support AirTable. Since then, it seems that a choice component will often default to a single relation if one is present in the attached table. Which usually isn’t what you want. So you need to be aware of that and change it before you can select some other table as the source.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.