Audio player not showing play / pause states

My app’s URL:

When I play audio on web, then play button changes to pause state (which is correct).
On iOS, the play button doesn’t change to indicate audio is playing.

How do I fix this?

It seems there is some kind of issue with the iOS player. On my iPhone 6s Plus at first it seemed to play and pause fine without issue. On iOS, different from my macOS, the player offers 2 additional icons to fast forward 10 seconds or back 10 seconds. If you tap on those it seems that it continues to play the original audio position but overplays another instance of the audio, 10 seconds back or forward, on top of the already playing one. In fact it seems that you can play it more than even twice and at that point the play/pause button visually toggles but the audio does not stop. Very strange behavior. I doubt it’s a Glide issue however. It seems like an iOS issue.

Yes I ended up with several instances of the mp3 playing.
iOS issue: How is this worked around? Client won’t enjoy this bug.

I have no idea of an iOS workaround. Now that I think about it, it could be a bug with the Glide audio component.

Is this forum the best way to report such bugs?


What happens next? FYI here is a screenshot of the player when the audio has already begun playing:

You can see that the play button is still clickable and the progress indicator is still at 0:00 even though it’s been playing for a few seconds.
Clicking play again (to pause it) simply plays a second instance of the audio.

Which iOS version is this?

Alright, I can reproduce this.

@david Latest version, iPhone X

Is this being worked on? A client wants this feature and it’s not reliable at the moment.

We’re looking into it.

Legend. I’m worried about what I’ve sold the client on if this feature isn’t working as intended :slight_smile: