App published and isn't showing data entered before publishing

UPDATE: it’s responding now, but it doesn’t have the data I added before I published it. (It’s in normal mode.) Can I force a refresh?

ORIGINAL I published the app (for Thursday’s conference) and it worked fine. Came back later and it says it can’t load because the server stopped responding.
Is this a Glide thing or is my app broken? App link is here: ConvergeSouth Conference

What kind of data source are you using?

This is our first app. All our data is in the Glide data sheets. I added a column this morning, added data, the app looks correct in the editor/builder and THEN published it hours later. But the published app is missing a chunk of data.
This is the published app: Screenshot by Lightshot
This is what it should look like (done before publishing): Screenshot by Lightshot

Have you tried republishing? I’m assuming that you have automatic publishing turned off, meaning you need to manually publish?

In your screenshots, you show a new block of text. Was that part of adding a new component, or did the component already exist and you just added data? I’m assuming it’s new data and a new component since you mentioned adding a new column.

Also curious of the favorites button exists in both the old and new version. I wasn’t sure since I can’t see it in your new screenshot.

If republishing doesn’t help, can you show a quick screenshot of the new column you added?

I don’t know how to republish. I’ll go check the docs. The new column is here: Screenshot by Lightshot
There’s nothing in the docs about republishing. How do I do that?

I didn’t answer one of your questions. I added a column with text to the original data sheet. That’s the “session description.” It looks fine in the editor, not in the published app. That favorite column? I didn’t put it there, it likely came from the template I used. It’s not a concern right now.
I’m also seeing another edit I did last night not coming through on the published app. Again, I edited text on an original data sheet column. The editor shows the time and location, the published app isn’t showing the location: Screenshot by Lightshot (that’s the one in the editor). Both were done hours before publishing.

I definitely see a problem. Your Session Description column is set up as a user specific column. That means that whichever user you were previewing as when you added the data in that column (most likely as yourself), then that data only belongs to you specifically. If you were to sign into your published app, you would most likely see the session description, but nobody else will. You created that data as user specific so only YOU as the user can see what YOU entered into that column. User specific columns hold different data for different users, but in the same cell.

You will have to re-create the column again, but make sure that you do not select ‘User Specific’ when adding the column. Then change any parts of your app that need to use that new column.

I would also check to see if this is the same issue in your last screenshot.


As for publishing, maybe you already have it set to automatic publishing. That is the default. You can switch it to manual publishing if you choose. I had assumed you already had the app published and you were manually publishing updates, but now I think I understand that you were talking about publishing for the very first time.

You’re not just an expert, you’re my hero. I just made a new column and pasted in the text. Edited it and it works perfectly. I’ll fix the date/location thing, now that I know what the terminology means.
As for publishing, I never changed default settings and got a little nervous that the URL would change (the QR code is already printed all over the place).
Thanks for everything. Really, you have been so helpful!

1 Like

The blue icon in the heading is what told me it was user specific.

You can click on that Publish button at the top right of the builder at any time. You don’t have to worry about anything like the url changing on you.

1 Like

There is no publish button in the top right of the builder (it used to be there, till I published it). Now it says “Business Project.” I understand what “user specific” means now and it’s useful. Next time :slight_smile:

1 Like

Just next to that, you should see a Share button. If you click on that, there should be a sub-menu appear, and you’ll find Publishing Control in that sub-menu…


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.