Airtable not updating and being a dead end

Glide is not updating with Airtable. From either app it will not update/show on the other.

Also if I’m creating a new app and want to use data from an airtable base it is not possible to select as it will keep waiting for the bases to appear with no possible button to click therefore being a dead end. Anyone has encountered/managed to solve this?

Glide’s integration with Airtable is still not matured I guess. Glide’s own database is so powerful, I would use it instead of Airtable.

I don’t agree with this.

Manipulating data in glide tables is not an easy exercise. I much prefer keeping my back end in Airtable.


May you give us an example to understand your statement and know the differences?


Of course! Just my opinion though - and how I find it with my particular use case (don’t want to start an argument)

Unless I am missing something, when using Glide tables I find -

  • searching for a particular record or field in Glide Tables tricky. Lots of scrolling back and forth / up and down. Yes I can use the Data Peek in the builder - but that often doesn’t show me the record I need

  • Entering data / new rows fiddly.

In Airtable I can

  • Create several views with just the records / fields I need to see

  • Group records by a value - which often helps view and analyse data

  • Sort records - so that the latest record (for example) - always appears at the top

That all said - I love some of the field types in Glide (Relative date for example) - which is so well implemented - and the lack of native support of single / multiple select and linking records is disappointing (though can be worked round).

Just my thoughts though. I personally could not rely solely on Glide Tables to build. I also like keeping my back end and front end entirely separate so that I am not reliant on one product.



For what it is worth - all seems to be working for me (Airtable to Glide)