Adding a source within tabs

I am new to glideapps. I simply am wanting to add a new tab, then choose the source that matches it. When I click the plus sign in tabs to add a new tab, this works perfectly. I name it what I want, then go to the box below where it says “source”, and the source I need isn’t there. It instead wants to add the tab to an existing source.

Example: I am trying to add the tab “Health”. I click the plus sign, add a tab and call it Health. I then go to the source box, and Health isn’t there to choose from. I’ve tried adding a label called “Health” within the spreadsheet but it still won’t show up in the source.

Any help would be greatly appreciated!

Do you have any headings in your health sheet tab? Have you clicked on Reload?

Yes, and I have refreshed the spreadsheet and the glideapp on my computer. The tab has been added on the bottom, but it put it in home or one of the other tabs that are already there if I choose those. I just can’t figure out how to get “Health” as a source, as all the other tabs are. Thank you for the reply.

Besides reloading the browser, have you clicked on the reload button in the builder? That should refresh and grab the Health tab from the sheet if it’s new. Sheet tabs with no headings in them will not be loaded in Glide.

Do you you have any screenshots showing the tab in the sheet? Also any screenshots where it’s not showing as an option when adding a new app tab?

I never even noticed the icon below the pen on the left side. Mine is grayed out and I can’t even click on it. Is this the reload you are referring to? Maybe this is the problem? I definitely have the health tab in the spreadsheet with some titles.

Yes that’s the button I’m talking about. It’s not grayed out. It’s hidden behind an overlay, so you’ll have to zoom out on you browser.

Thank you so much! I was searching and saw that on another post you mentioned adjusting the zoom. Sure enough, that was the problem. It wasn’t greyed out anymore and it fixed everything. Thanks so much!!!

1 Like

Fixed, thanks!!!