"Add element to set" not working?

I use “Add element to set” in a few apps, and it seems to not be adding the element anymore. Likewise remove element isn’t working.

It should be able to add elements in the format of x, or [“x”] or [“x”,“y”]

But from this table, with “String set” and “Element” columns used, you can see elements aren’t being added.

Is this a known issue? Any anticipated time till it’s fixed?

Not sure if this is a “known issue”, but I have raised it with Glide a couple times now. One of the issues I’ve noticed is that the action fails when the destination column is blank (marked in Red)

The ones marked in Orange should work as an Action…not sure why they’re not working as a column. Try as an action to test.

The ones marked in Black are unknown. I’ve never attempted to add sets to sets.

1 Like

Thanks for checking this out.

I noticed before the red “Known” issue, but I got around that simply by initially setting the empty set from empty cell to .

I’ll check if the orange works as an action. I know it used to work just like this, in a computed column.

The black ones I haven’t actually tried in the past, but according to the placeholder text in for the add element to set column, it should work.

Your orange cases, adding single element (not single element set) does work by action.

Trying to add sets, just puts the set as a single element.

So, why aren’t the orange cases working in a column? They used to back in early summer. The app I used it in before and it worked, I see the column is no longer functioning correctly.

I guess I’ll submit a ticket.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.