User Specific Column not working


I have a user specific column called UID which gets incremented when I click on “First Note” or “Second Note” button. Somehow, the UID column is showing the same value for all the users.

Here’s the link to the screen recording of the issue:



Have you tried choosing another user and refreshing the builder to see if the number changes? What should it show when you change to a new user?

Yes. I just tried refreshing the builder but no luck. The thing is the increment happens in +1, starting value is 101. If I click 2 times for a user, then the final value of 103 should be there only for that user. Once I switch to other users, it should still show 101.

But in my case, this is not happening.

Does the published app behave in the same way, or is it only in the builder?

Same with the published app as well

It seems like the USC feature is not working at all. Just tried a very simple example.

Created one USC column called Comment → Added a comment from the user called Tamsin → switching users is showing the same comment

Here’s the video:

Kindly help. Not sure what I’m doing wrong.

Are you able to provide a copyable version of your app that I could take a look at?

Facing the same issue here!

For me it’s working on apps that already created but not for new apps!

Darren, can you check this behavior by creating a new app?


I know that NCM was enabled for new Glide Apps last night, so it might be related to that change.
I’ll do my own testing, and if I can replicate it then I’ll report it.

Update: Yes, confirmed. I’ll report this.


Thanks for the help Darren. Hope it gets resolved quickly.

Just one thing regarding this.

I did some additional testing, and I found that it does work correctly (at least for me) in the published app. If I log in as two different users, I find that the user specific values are correct for each user.

It’s only in the builder where the behaviour is inconsistent. Sometimes it works, sometimes it doesn’t.


@Darren_Murphy Yes, I was able to verify the same. It was not working for me earlier but now its working fine. Editor & builder is still buggy though