User aborted request - OpenAI

Hey folks , getting this error on a lot of my OpenAI columns for some reason all of a sudden?

Any ideas as to why this might be and how to rectify? Its basically crippling my apps functionality

Screenshot 2023-10-17 at 12.47.39

1 Like

I have the same issue but with actions


Is this perhaps related to OpenAI limitations for your account type? Maybe even needing to top up your account?

Has it been solved since then for you? Is it an intermittent issue?

Its happening less now but still happening.

It happens on certain columns at certain times. Not an issue with API limits either , way below monthly limit.

Can anyone from the support team look into this?

@Emmett_M definitely a problem that must be solved. The user cannot do anything about it. Not ok for business plan


1 Like

Is the rate limit the issue for you or separate? I do not have this error.

I’ve also changed my API key but still getting the errors.

@Emmett_M I have both the The usser aborted a request and rate limit. It is in the same column using openai chat (without history).
Needs to be fixed

1 Like

Yes, it is an intermittent issue. For the last 2 weeks, I have faced this problem almost with one action, and it is working from time to time, depending on the task I ask him to do.

1 Like

@NoCodeAndy @david is this something the team could look into for us?


I am having the same issue. I have changed max tokens and everything and it only works occasionally.

I have a feeling that Glide automatically times out if it takes OpenAI too long to respond. I looked up the OpenAI forums and apparently GPT-4 has been quite a bit slower in the last 2 weeks:

A few things could be useful here:

  1. Does Glide automatically time out at certain point if no response is received? @david
  2. Is there a way to increase the time before Glide times out?
  3. Is there a way to set a condition in Glide Actions to go down a new path if Glide returns an error like The user aborted the request?

Here are some other things I have tried that haven’t worked:

  • Buy credits to increase rate limits with OpenAI
  • Changing max length
  • Generated a new API token with OpenAI

Edit: After investigating this further I have identified:

  1. User abort issue happens with gpt-4-0613, gpt-4-0314, gpt-4
  2. It works with: gpt-3.5-turbo

Edit2: I tested the exact same request in Postman using gpt-0613:
The request worked - the response time was exactly 2 minutes:
CleanShot 2023-11-02 at 10.08.14

I also found this forum post in relation to the CallAPI:

It seems like when Glide times out, the API aborts a request, so longer responses like for gpt-4 requests are likely going to be aborted.

I’ve only been using gpt-3.5-turbo and still having the issue.

Again , for probably the last 2 months I had no issues with the same config only up until recently did i notice some columns not generating and giving this error.

Yeah, if you check out the OpenAI forum post, you will see that there were are few others having issues with GPT-3.5-Turbo.

It looks like it is related to tiers that OpenAI has put users on.

You get promoted through different tiers, as you pay more for API usage. Some people have solved slower reponses times by buying credits and moving up in tiers.

It seems to be a reasonable new issue.


Interesting , I would still like to hear from the Glide team on what they can see from their backend thats prompting the error within Glide columns.

I;ll keep trying some different configs in the meantime

@Jason probably knows the most about timeouts in the integrations layer


We’re still experiencing this issue, so we’ve swiftly shifted all functions from GPT-4 to its 3.5 Turbo. While this has had some impact on performance, it’s restored the application’s output delivery capabilities. We’re currently on standby for a resolution to this bug and would greatly appreciate any expedited support on this. @Jason @ThinhDinh

I also moved our AI App Designer from gpt-4 to 3.5-turbo to work around this issue.

1 Like

I’ve only had the issue with 3.5-turbo , no columns using GPT 4

guys I just moved on gpt-4-1106-preview and it’s amazing

1 Like