Having problems. I am upload a file which is being converted to a path

When I am displaying information in the new app it is showing the pull path, in the legacy system, I could configure the link component to show only the last part.

I am trying to use regex but it doesn’t seem to be working. I tried using
to strip off everything after the last “/”

If you mean, that you need to leave the file name, so usually i use Slit text /
and then Single value last

yes… I want to end up with price_json.txt

is that 2 columns you are using ? Slit text and Single value last ?


mm… not working for me… not sure what I am doing wrong

What’s actual result?

You needn’t go thru table, you must go directly to row column

Single value will not work, it is copying the same results in each row, I need it to split for each row.

Currently it seems to be be taking the last row and of the split column and copying it in every cell of the single value

Look at my screen carefully. You going to select column thru table, but you need to choose column in row

1 Like

oh yes… my mistake…

Thanks, I will implement this, although not sure why the regex doesn;t work.


What’s the end goal for displaying it? A Link component will display just the file name while also providing a clickable link. Not sure if that works for your use case though.

Thanks, Jeff for income! Can you show example how link component can show only file name, please

Hi Jeff,

That is what I am trying to do.

I am using the link component, but the file name now contains the full URL which I don’t want to display

I don’t I ever did anything special. This is how it looks in one of my apps. I think the difference may be that I’m using a Multiple Files column to upload multiple PDFs and then display them with a Link component.

I didn’t have a Title option, so it must have done it automatically.

1 Like

ahhh… got it. I am using a URL column and that is why I am having this issue.


1 Like

Multiple files columns will take care of that automatically for you, but they are not prettified (the %20 escapes for spaces are kept, for example).

When you have a non-array column, the component allows you to specify the title.

Here’s my attempt on fixing the error with multiple files.