Power Automate // Glide

Hell all,
I am having a big problem at the moment. I am trying to use the trigger function in glide. I want to make use of the webhook function. I have made a flow in Power automate, i have the webhook url, which i have added to the trigger in glide. However, no matter what i do it does not trigger the flow in Power automate. I have tested the url in Postman and it works fine but for some reason it Glide does not seem to call the url.

I checked if this maybe an issue with Microsoft and we tested the HTTP url on several times using postman and some alternatives and it always works. However, it never works when i insert the url in
glide.

Does Glide just not work with Power automate?

Hi! I think you can trigg Make.com and make.com can trigg Power Automate, May be

Hello,

Yes, this solution works but it is not ideal.
Do you know if Glide somehow block Power Automate?

It depends how you’ve set it up on the Power Automate end. I’m a Power Platform Consultant btw so should be able to help you with this one :wink:

Use the “When a HTTP request is received” module in Power Automate to watch for the webhook:

You’ll need to create the schema from sample data sent from Glide and Parse the JSON to get the data.

Hello Wayne,

I could really use your advice on this!
I have used the “When http request is received” module. I have also tried to leave the body empty, tried with only {} and tried with the actual scheme but nothing works.

I tested the HTTP post URL generated by the module in Postman and it works but when i add it to the Glide trigger webhook feature it does not work. I click the button and nothing the flow never gets triggered. Is it possible that either glide can’t accept certain length URL’s or maybe just Microsoft HTTP Post URL?

Do you know if the webhook is being received in Power Automate at all? It should. Leave the request body empty and put a response after to check. Once you know the response if getting through then focus on the data structure… I haven’t tried to myself but I will shortly and see what I get for you.

Hello Wayne,

The HTTP post does not get called. It is not as if the Module HTTP Request is triggered but it is giving me the wrong output.

The HTTP URL does not even get a response at all when I paste it into Glide “add webhook” and click the button.

I have added different URLs from either postman or Webhook.site and pasted it into Glide button and when I click the button it. There is a response by both URLs.

At first I thought maybe the URL is too long and therefore Glide does not call the URL?

I get the same results. Looks like a bug with Gilde. A ticket will need to be raised I think.

@Wayne_S want to meet in about 30 minutes to try together?

@david I’d would love to but almost 8pm here, family time! Happy to do a time tomorrow, my calendar is pretty clear.

Hello Wayne,

I am glad to hear the issue is not just on my side, spent 2 days trying to figure out the cause!
David/Wayne if either of you are able to figure out how to resolve this, please do let me know!

1 Like

Hello David,

I am also free anytime, please do let me know if you are free so i can show you the issue.

Hello all,

Any update on the above?

Look forward to hearing from you.

Hello David,

Any chance you were able to resolve this?