Not able to check if a number is included in a joined list

No that won’t work.
If your goal is to prevent duplicate entries, then a better way to do it is to create a multi-relation between the user-supplied number and the current numbers. Then check if that relation is empty. If it’s not empty, then you have a duplicate number.

I create a relation column “Contact Relation” which relates Contact Phone Number with Contact Phone Number in the same sheet. Then, when user is adding an item using the Add button on the top of a tab, during submission I have the check using condition Contact Relation is empty, but it is not checking
image
image
image
image

Yes, that’s expected. If you’re using Add Form then the relation won’t be formed until after the new row is added. In order to use this technique, you need to create a custom form and write the input number to a User Specific Column. Because USC’s are populated as the user enters the data, the relation will form immediately, and you can intervene before a new row is added.

2 Likes

I made the phone number user specific. But, now it is not showing up when I try to add a number entry to the phone number column. Is it because, it is user specific? I created a form button and then tried to add the two fields. Only the txt field for name appears, but not able to select a number entry to assign to number column which is user-specific.


On the right side, there are only two fields, but not the number field.
But, the sheet has number field.

What @Darren_Murphy means is you should use a link to screen action, then add entry components and use an add row action to have the same flow as a form.

With your screenshots, you’re trying to write to a user-specific column in the destination sheet, which will not work.

@vijay here is an example of what I mean:

1 Like

Thanks for the app which helped me understand how it can be done. But, when I tried the same thing, I find that when I try to Add Row, I am not able to see the components usc name and usc phone number. I created usc name and usc phone number to store the entries temporarily as you have done. I also selected This item in Link to Screen.


Which table did you create the User Specific Columns in?
By looking at your screenshots, they should be in your Contacts table.
Also, I would advise always using a custom action - even if it’s just a single action. Because inevitably you will come back later and need to add extra steps. If you start with a custom action, then that is easy.

Yes, there are in the Contacts table.


And your Phone Entry and Name Entry input components are targeted at those User Specific columns?
That should work.

Yes, it is, but strangely, the columns are refusing to appear.

Does it need some data to be entered for it to appear?

When you enter data in those input fields, do you see the same data appear in the User Specific Columns in the GDE? (in your Contacts table)

Yes, it does appear.


It is happening on the Contacts tab.

One difference between your app and my app is your app consists of only glide tables, while mine are in Google sheets. I tried the same on a new glide table in the same app, and this issue is not there. So, I think it may work only on Glide tables.

No, that’s not true.
I use this technique in every app that I build, and 99% of those use Google sheets.
I don’t know why it isn’t working for you. If I could see your app, I might be able to explain it.

1 Like

I tried creating a simple test app, and the same issue occurs with a Google sheet and a user specific column.


If you make it copyable, I’ll take a look.

Done. Made it copyable.

because is on the deferent sheet

Seems to work fine.
I can enter any value in the text input, and use that to add a new row.