Fetch Column

I’m receiving a
TypeError: failed to fetch

It’s likely because your API doesn’t allow cross-origin requests, as David said. It’s not something Glide can control.

Okay thanks. Just figuring things out will try a different api

I just learnt that I cannot share an app that has an experimental column in it. All well.

After watching your video and reading the thread, I played around a little with your concept. Here is the little concept app I built: location search.


  • Ability to: Search for locations with keywords. Save locations. Change city or country searched.
  • Search is supposed to display a map, exact name and address of the location searched. Use of the Geocoding.ai API and whatnot.
  • Ability to save a location, edit it (user can further enrich data manually) and delete it.

Nota bene

  • It’s buggy. After a few searches the search feature stops working. I do not know if the bug comes from API limitations, data edits in the tables, the developer (me), or something else.
  • For some reason the data from the API doesn’t always display in the Glide Table, though it does as soon as I look at the table. I think this is preventing me from building the “Avoid duplicates” feature I tried to build.
  • I wanted to pull additional information such as storefront image, URL, phone number, but didn’t manage.
  • I made the app public and I meant to make it copy-able, but apparently I cannot.

You could always just remove the offending column and then provide instructions for adding it back in.


Nice. Works well in the browser.

Very nice! Works well here.

I’ve played around a lot with it, and it feels off.

Limited data from the API request
When you use Nominatim, I noticed then when you search for a location, their are more data points in the details screen – namely phone number, URL – than in the API request. I wish I also had the storefront.

Hyperformula column
I used this to apply =right() and =left() GS formulas to some of the data returned by the API, and I noticed that though the cells in the GT seem empty, the data is actually there because I can then use the Hyperformula column for other computed columns. But because the column seems empty, I still feel like this is having an incidence on a relation column I need to avoid duplicates.

It’s a shame it cannot be copied, I’d be happy to pass it along as it is. :man_shrugging:


@david See Darren’s Fetch vs. David’s Fetch here:

From my testing, both work on:

  • Google Chrome on Android
  • Google Chrome on PC
  • Google Chrome on macOS 11

But David’s Fetch returns nothing on:

  • Chrome on iOS 14
  • Safari on iOS 14
  • Safari on macOS 11

You mention here, you think there are Safari iOS 15 issues with the Experimental Code column. This may be true, but there is also an issue with column.sh.

Darren’s Fetch is using: https://replit.com/@darrenambles/fetch
David’s Fetch is using: https://column.sh/fetch

I’ve seen the same issue when trying to use: https://column.sh/hell-yes-code

P.S. On the admin app last week, I had to roll back the change to use https://column.sh/fetch because it stopped working the next morning.

1 Like

I will try hosting them on a different domain to see if it’s a domain configuration thing.

I will add that my fetch also has an in-memory cache now.


You can always replace the forward slash with a comma if all you want is the lon-lat.

1 Like

Just wanted to update here that my issues with the Fetch JSON Plugin not working on iOS have been resolved.

Also I created a beginner friendly tutorial showing how to use the Fetch Column here:


just wondering, is there a way to display the array values of any of those rows in its own in-line list perhaps?

eg; display the values highlighted below in an in-line list


Ya. Create a multiple relation of that array back to a source of some type. But…if fetched…I imagine those values don’t live in your sheet?

Just thinking out aloud, I wonder if he could use a single value to take the first item from the array, and then use that to create the relation? :thinking:

hmm, or even just a self-referencing multi-relation might do the trick?

that’s correct, the values don’t live in Glide but rather in Firebase.

I can pull the entire tree branch from Firebase that contains each object in an json structure eg; list of Venues

I am now trying to display them in an in-line list.

@Rogelio Can you dynamically add row numbers to this table? If so, I have an idea.

I’ve tried a self-relation (multiple) back to itself using a standard text column, but it doesn’t quiet work, as the list I want to display it’s contained in an individual column of the sheet that contains a single row.

What I’m thinking is create a row number in each row and start with 0. Then add a single value column that looks at that array. Choose “from start” > Row number. This should put each value on its own row. Then you can display it in an inline list.

1 Like

This is obviously not exactly what you are looking to do, but I was looking for a way to display multiple items in a list from a fetch.

Rather than inline list (for now), I replaced the JSON elements I didn’t want ( [, ", ".) with HTML tags and created an unordered list for display purposes. I am using a rich text element for display on the page. Not as nice as an inline list, but still much better than a long paragraph of items.