Api call crash the whole flow when gets an error

Im building a delete button on my app that erase multiple rows from multiple tables, its looks like this:


The problem is that sometimes this tables doesnt have data in it, so when i run the action, some api calls work, but when they meet with empty data, the api returns an error, and the next api calls (that came after this one) stop working.

The way that im building this json it looks like this:

  1. i build the simplejson part of it:

  2. Next i append every last json to a mayor one, separated with “,”, like this:

  3. And then i put all those jsons on mutations, like this:

  4. And finally i run that whole JSON with the corresponding headers, api-keys, etc.

how can i fix this?


You know you can just do a Delete Row action through a single or multiple relation without having to mess with the API.

Hi Jeff!

yes, i know that, but that would just delete a single row per table right??

I have to add that this delete button will only delete information from the active users, not from everyone

Not unless it’s a multiple relation, then it will delete multiple rows.

1 Like

OMG thanks!!!

1 Like

Also use JSON Object and Lookup to construct JSON, not Template and Joined List

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.