How to insert line break into email body please

Little help please!

I have a button set up to compose an email:

and it uses this template to form the body text:

The line-breaks are correctly inserted when I preview the email using MS Outlook on my Laptop and it all looks great. But when I test it on my iPhone (MS Outlook app for iPhone) the draft email inserts the code ‘

’ as opposed to actually inserting line breaks.

Is there a workaround please? Hopefully without resorting to any Zapier integrations or the like.

Have you tried using some HTML tags, either <br> and/or <p>?
I think most email clients will deal with HTML tags these days.

Yes, I inserted the standard characters
but they just get inserted as text. (at least I tried the br but not the p)

hmm, you might need a doctype declaration, ie <!DOCTYPE html>, so that your email client recognises it as HTML. Sorry, just guessing really - I’ve never used the email action - I use Integromat and/or Apps Script for all my email needs :slight_smile:

1 Like

Just tried with the p inside the symbols and that doesn’t work either.

How are you typing your line breaks? Usually 2 spaces and a carriage return works pretty well.

Hi Jeff,

I didn’t think I was doing anything unusual… but just went back and carefully added 2 spaces and then hit enter to force the line break. Did this in a few places… but still no success.

Could it be the Template is not compatible with forming the body text when composing an email?

Hmm, I know that works for something like a rich text component, but maybe the email client ignores them. I’d be curious if you added a copy to clipboard button to copy the template and paste it in the email client.

Maybe that works… but not great for UX… thanks anyway.

1 Like

I understand. I was just curious how it reacted with a copy to clipboard and a paste. Not as a final UX, but just to test and see if the carriage returns are kept or not.

here is an example how to do it in Glide App: SAMPLE

@Uzo in your app there’s only the option to add the recipient, not the email body…

You want a body too? :wink: i made this sample to show email response… so just email is good to test it… but no problem to add body…or bunch of other things, and for the topic… you can see that there are breaks in the email text

Just saying because that’s what this thread for

2 Likes

And not only break’s… pictures, colors, links…
@Lucas_Pires i added the body… you can test it now: LINK
it will add breaks in your email body.
And you can even put HTML there :wink:

Hi Jeff,

So I duplicated the button and changed the action to ‘copy to clipboard’ as you suggested. A nice experiment.

And I was intrigued to discover that on my iPhone, when I copied the message to clipboard and then manually opened the Outlook App, select ‘compose new email’ and then pasted into the body of the new email - it worked perfectly. The breaks were respected (and by the way, I deleted the characters with Br or P and just had the template include standard line breaks).

So somehow the formatting is lost after passing the template text to the ‘compose email’ task.

1 Like

That eliminates the template as the source of the problem. I’m not sure how the compose email button transfers over to the email client, but it might be a limitation of the OS or email client. Might be worth trying different devices (Android / iOS). Also might be worth changing the default email client (such as Gmail) to see if it’s an issue with Outlook or not.

1 Like